Bug 57793 - Loader problems in 7.2
Loader problems in 7.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-22 20:50 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-22 20:51:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-22 20:50:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Lilo gives "L" prompt and fixing it from the install CD fails.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have a working dual-boot system running with 11 partitions on /dev/hda. 
Debian on /dev/hda2 boots off a lilo using boot=/dev/hda

2. Put in a 6GB drive as /dev/hdc and install a plain-vanilla RedHat 7.2 
on it. Tell RedHat to use lilo with boot=/dev/hda root=/dev/hdc1 (in point-
and-click terms, that is)

3. Realise that lilo gives the "L" prompt and then hangs and try to 
reconfigure the loader with the installation CD


Actual Results:  I got the "L" prompt. To mend this I inserted the CD and 
booted into the installation program again. After choosing gurb as the 
loader and not changing anything else, the install program finishes by 
saying "no kernel packages were installed on your system. Your boot loader 
configuration will not be changed." This message was repeated even when I 
tried to boot the install program to reconfigure lilo.

Expected Results:  I expedted lilo to work "out of the box", because it 
did just that with an older debian system (I believe it is 2.0 or 2.2) on 
my hardware (Athlon 1GHz, 40GB hd). 

I also expected the install program to actually perform the updates I 
requested. 

Additional info:

I got my old system up and running again (with a working lilo that is) by 
booting it off debian rescue discs with a 2.2.18 kernel.

My own guess is that lilo fails because the partition containing /boot 
(/dev/hdc1 on the RedHat system) spans more than 1024 cylinders. BUT a 
message about that should be given during installation.
Comment 1 Doug Ledford 2002-01-16 21:54:33 EST
Installing to a system with two distinct / filesystems (one Debian, one Red Hat)
and also two different /boot partitions (I'm assuming this is true, your email
wasn't specific on that point) will never work as long as both Debian's version
of lilo and Red Hat's version of lilo are fighting over the same master boot
record.  This isn't a bug, it's simply not possible.  What you have to do to get
things working is add a /boot2 partition to both the Debian and Red Hat root
filesystems and under each OS you need to mount the other OSes /boot partition
as /boot2 (or choose another name if you wish).  Then, the lilo.conf file in
Debian needs to be made aware of both operating systems kernels and then you
need to rewrite the master boot record from the Debian operating system.  If the
/boot partition of the Red Hat installation spans more than 1024 cylinders, then
you won't be able to update the lilo boot record from Red Hat reliably, so don't
even try, just boot into Debian and make and kernel changes in there (if you
have to, install updated kernel RPMs from Red Hat into the Red Hat operating
system without making any changes to lilo.conf and without running lilo by
passing the --no-scripts option to rpm, then boot into Debian and make the lilo
changes there and rerun lilo, then you can boot back into the new Red Hat kernel).

Note You need to log in before you can comment on or make changes to this bug.