Bug 57803 - Upgr to 7.2 and pinging hostnames yields high packet loss.
Upgr to 7.2 and pinging hostnames yields high packet loss.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-23 17:01 EST by Need Real Name
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 08:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-23 17:01:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16-0.9smp i686)

Description of problem:
I upgraded my workstation RHLinux system from 7.1 to 7.2. When I ping any
IP addr or hostname on my internal network all is ok. When I ping any IP or
hostname on my internal net or on the internet from my Linux iDSL firewall,
all is ok. When I do IP or host pings from my 2 Windows computers all is
ok. When I ping my iDSL router address, gateway address, etc. all is ok. 
BUT WHEN I PING HOSTNAMES ON THE INTERNET FROM MY NEWLY UPGRADED 7.2
RHLINUX WORKSTATION, I GET VERY HIGH % PACKET LOSES 50% AND UP. BUT PING
THE IP ADDRESSES INSTEAD AND PING SHOWS NO PROBLEM.   Seems like some kind
of lookup issue local to my newly upgraded RHLinux 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgr 7.1 to 7.2 plus Errata updates for 7.2
2. Ping internet HOSTNAMES versus IP addresses to see packet loss
difference.

	

Actual Results:  [phb@boaz phb]$ ping redhat.com
PING redhat.com (216.148.218.197) from 192.168.100.1 : 56(84) bytes of
data.
64 bytes from 216.148.218.197: icmp_seq=0 ttl=236 time=109.236 msec
64 bytes from 216.148.218.197: icmp_seq=1 ttl=236 time=110.064 msec
64 bytes from 216.148.218.197: icmp_seq=2 ttl=236 time=109.567 msec
64 bytes from 216.148.218.197: icmp_seq=3 ttl=236 time=110.819 msec
64 bytes from 216.148.218.197: icmp_seq=4 ttl=236 time=110.325 msec

--- redhat.com ping statistics ---
14 packets transmitted, 6 packets received, 57% packet loss
round-trip min/avg/max/mdev = 109.236/109.993/110.819/0.508 ms
[phb@boaz phb]$ 

[phb@boaz phb]$ 
[phb@boaz phb]$ ping 216.148.218.197
PING 216.148.218.197 (216.148.218.197) from 192.168.100.1 : 56(84) bytes of
data.
64 bytes from 216.148.218.197: icmp_seq=0 ttl=236 time=110.816 msec
64 bytes from 216.148.218.197: icmp_seq=1 ttl=236 time=125.453 msec
64 bytes from 216.148.218.197: icmp_seq=2 ttl=236 time=111.148 msec
64 bytes from 216.148.218.197: icmp_seq=3 ttl=236 time=113.947 msec
64 bytes from 216.148.218.197: icmp_seq=4 ttl=236 time=109.515 msec

--- 216.148.218.197 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/mdev = 109.515/114.175/125.453/5.836 ms

Expected Results:  Pinging hostnames should not yield packet losses.

Additional info:

This behavior only started since 7.2 upgrade.  Note this workstation is the
only one having this issue.
Comment 1 Trond Eivind Glomsrxd 2001-12-28 06:01:00 EST
This has nothing to with xinetd. If it was a software problem (and not just your
network, which I think is the most likely problem), it would be a kernel
problem. Reassigning.
Comment 2 Need Real Name 2001-12-28 08:46:00 EST
Ted - it is NOT my network - if you read my overview, you would see that when I
ping anything internal including my firewall network cards and my idsl router
and gateway etc. IP or HOSTnames, there's NO PROBLEM.  Also from two other
computers on my network - WIndows PCs' - I can ping hostnames and IP addresses
both internally on my network, and externally on the internet WITH NO PROBLEM. 
IT'S ONLY FROM MY RHL 7.2 WORKSTATION PINGING EXTERNAL INTERNET HOSTNAMES I AM
GETTING HIGH PACKET LOSS - BUT PINGING THE IP ADDRESSES IS FINE.
This problem appears to COME and GO - like right now it is fine, but I could
find no valid reason for its occurance.     Besides this only started to occur
since the 7.1->7.2 upgrade, and under 7.1 I did not see this problem.

I understand inetd is not the culprit, probably kernel.  I am using k2.4.16-0.9
for maximum ext3 patching.  

I understand you should re-assign to kernel guys....fine.

Thanks!
Comment 3 Arjan van de Ven 2001-12-28 09:16:20 EST
there's a quick test you could do to see if it might be the kernel or not.
Can you add the hostname/ip pair you're testing with to the /etc/hosts file.

The reason I ask this is because if this would fix it, it would be a DNS 
thing, and the kernel has nothing to do with DNS. If the problem remains, it 
MIGHT be kernel; however the difference between "ping by name" and "ping by number"
is strange.

Also, it appears that the sequence numbers of the pings are ok (eg sequential);
this would mean there's "just" a delay, not a random loss. 
could you try using "ping -n hostname" (eg the -n) ?
Comment 4 Need Real Name 2001-12-28 10:25:00 EST
Ok Arjanv... here's the test results for you....

========================================================
PING vs. PING -n RESULTS (before I put hostname into /etc/hosts)
========================================================

PING RESULTS FOR HOSTNAME ON INTERNET

[root@boaz root]# ping trimatrix.com
PING trimatrix.com (192.41.49.147) from 192.168.100.1 : 56(84) bytes of data.
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=0 ttl=236 time=142.451
msec
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=1 ttl=236 time=141.966
msec
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=2 ttl=236 time=142.450
msec
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=3 ttl=236 time=144.212
msec

--- trimatrix.com ping statistics ---
9 packets transmitted, 5 packets received, 44% packet loss
round-trip min/avg/max/mdev = 141.966/142.758/144.212/0.802 ms
[root@boaz root]# 

PING -n RESULTS FOR HOSTNAME ON INTERNET

[root@boaz root]# ping -n trimatrix.com
PING trimatrix.com (192.41.49.147) from 192.168.100.1 : 56(84) bytes of data.
64 bytes from 192.41.49.147: icmp_seq=0 ttl=236 time=145.598 msec
64 bytes from 192.41.49.147: icmp_seq=1 ttl=236 time=144.899 msec
64 bytes from 192.41.49.147: icmp_seq=2 ttl=236 time=142.163 msec
64 bytes from 192.41.49.147: icmp_seq=3 ttl=236 time=145.408 msec
64 bytes from 192.41.49.147: icmp_seq=4 ttl=236 time=144.600 msec

--- trimatrix.com ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/mdev = 142.163/144.533/145.598/1.305 ms

============================================================
NOW I PUT trimatrix.com and IP into /etc/hosts AND HERE'S RESULTS
============================================================

PING HOSTNAME RESULT

[root@boaz etc]# ping trimatrix.com
PING trimatrix.com (192.41.49.147) from 192.168.100.1 : 56(84) bytes of data.
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=0 ttl=236 time=142.219
msec
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=1 ttl=236 time=143.150
msec
64 bytes from trimatrix.com (192.41.49.147): icmp_seq=2 ttl=236 time=142.787
msec

--- trimatrix.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/mdev = 142.219/142.718/143.150/0.580 ms
[root@boaz etc]# 

PING -n HOSTNAME RESULT

[root@boaz etc]# ping -n trimatrix.com
PING trimatrix.com (192.41.49.147) from 192.168.100.1 : 56(84) bytes of data.
64 bytes from 192.41.49.147: icmp_seq=0 ttl=236 time=144.348 msec
64 bytes from 192.41.49.147: icmp_seq=1 ttl=236 time=144.370 msec
64 bytes from 192.41.49.147: icmp_seq=2 ttl=236 time=147.068 msec
64 bytes from 192.41.49.147: icmp_seq=3 ttl=236 time=143.247 msec

--- trimatrix.com ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/mdev = 143.247/144.758/147.068/1.434 ms

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ALL THE ABOVE RESULTS ARE CONSISTANT.

FURTHER, PINGING IP ADDRESS NEVER SHOWS PACKET LOSS.

ONLY HOSTNAME WITHOUT -n OPTION WHEN NOT IN /etc/hosts,
AND ONLY HOSTNAMES WHICH ARE ON THE INTERNET
FROM THIS ONE RHL 7.2 WORKSTATION -ONLY-.  

BTW THERE'S NOTHING WRONG WITH trimatrix.com host ...
I could have used any other internet host - same results....
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Comment 5 Arjan van de Ven 2002-01-04 06:50:59 EST
Ok, this means it's a "ping" bug, not a kernel bug; changing to that
component.....
Comment 6 Phil Knirsch 2002-03-12 08:57:12 EST
OK, rawhide has an updated version of iptuils which contains a new version of
ping. It changed quite a bit, so if you could give that version a try to see if
it fixes your problem i'd greately appreciate it.

I haven't been able to reproduce your problem btw. here, neither with the old
nor with the new iputils package.

Thanks,

Read ya, Phil
Comment 7 Phil Knirsch 2002-06-19 08:44:12 EDT
As i can't reproduce this problem and haven't heard back i'll close this bug as
WORKSFORME now.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.