Bug 578109 - kpartx doesn't release it's loop devices
kpartx doesn't release it's loop devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Jiajian Yang
:
: 667086 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-30 05:08 EDT by Andrew Jones
Modified: 2011-07-21 04:21 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2010-03-30 05:08:00 EDT
When viewing partition information from a file (such as a virtual machine raw image) kpartx uses a loop device. It should release this loop device afterwards, but it doesn't with RHEL5's release (kpartx-0.4.7-34.el5).

A patch went into upstream 0.4.8 that corrects this issue.

commit e43df657f125af42779af54dca6183f023725d2d
Author: Hannes Reinecke <hare@suse.de>
Date:   Tue Oct 14 08:38:29 2008 +0200

    kpartx -l does not remove it's loop device
Comment 1 Ondrej Vasik 2010-03-30 05:26:36 EDT
Basesystem is just dependency metapackage, it has nothing to do with kpartx. It comes from device-mapper-multipath ... reassigning.
Comment 2 Ben Marzinski 2011-03-07 00:00:40 EST
*** Bug 667086 has been marked as a duplicate of this bug. ***
Comment 3 Ben Marzinski 2011-03-07 00:22:18 EST
patch applied.
Comment 6 errata-xmlrpc 2011-07-21 04:21:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1032.html

Note You need to log in before you can comment on or make changes to this bug.