Bug 578258 - authconfig does not setup sssd with ldap properly
authconfig does not setup sssd with ldap properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 636324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-30 13:49 EDT by Orion Poplawski
Modified: 2010-09-24 11:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 16:35:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sssd.conf file as created by authconfig (2.84 KB, text/plain)
2010-03-30 13:49 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2010-03-30 13:49:01 EDT
Created attachment 403535 [details]
sssd.conf file as created by authconfig

Description of problem:

On sssd live image, did:

# authconfig --enablesssd --enablesssdauth --ldapserver=ldap.cora.nwra.com  --ldapbasedn=dc=nwra,dc=com --enableldaptls --ldaploadcacert=http://www.cora.nwra.com/cgi-bin/getca.pl --update

and got:

Starting sssd: Cannot load configuration database
                                                           [FAILED]

Version-Release number of selected component (if applicable):
authconfig-6.1.2-1.fc13.i686
Comment 1 Tomas Mraz 2010-03-30 14:03:09 EDT
This is not the way the SSSD should be set up by the command-line. Using the --enablesssd and --enablesssdauth options forces startup of sssd but does not set up the ldap provider.


I suppose you want LDAP for both user identity and The correct way is:

authconfig --enableldap --enableldapauth --ldapserver=ldap.cora.nwra.com --ldapbasedn=dc=nwra,dc=com --enableldaptls
--ldaploadcacert=http://www.cora.nwra.com/cgi-bin/getca.pl --update

Of course you should run this command either on fresh install without any other network authentication set or disable all other network identity/authentication with authconfig call. You can find out the current settings with 'authconfig --test'.
Comment 2 Tomas Mraz 2010-03-30 14:04:50 EDT
I'll try to document that in the authconfig man page.
Comment 3 Orion Poplawski 2010-03-30 16:35:35 EDT
Okay, that works.  Sorry for the noise.
Comment 4 Orion Poplawski 2010-09-24 11:53:20 EDT
*** Bug 636324 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.