This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57835 - pppd Dial-On-Demand feature is broken in RH 7.2
pppd Dial-On-Demand feature is broken in RH 7.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-26 20:22 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:33:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-26 20:22:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When a ppp connection is defined with DEMAND="yes" 
in /etc/sysconfig/network-scripts, ifup blocks until the link is truly up, 
that is until someone asks something that brings the link up.
Also, the link never comes down.

Further more, the links that are defined with DEMAND="yes" block the boot 
up procedure of RedHat 7.2.

THIS MAKES RH7.2 UNUSABLE FOR DIAL-ON-DEMAND INSTALLATIONS.

RH7.1 with exactly the same ppp and link config files works as expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use rp3-config to define a ppp link with on-demand feature turned on.
2. enter at a root prompt: ifup ppp0


Actual Results:  The command blocks until someone requests something from 
the link.
Also, the link never goes dows automatically.

Expected Results:  The command should have returned immediatelly.
The link should go up and down based on the demand.

Additional info:

RedHat 7.1 works perfectly, with exactly the same config files.
Comment 1 Thomas Woerner 2004-08-13 05:33:09 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.