Bug 578390 - rpmlint complains about comments
rpmlint complains about comments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-31 03:30 EDT by Felix Möller
Modified: 2010-06-04 14:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: rpmlint-0.97-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 14:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Möller 2010-03-31 03:30:12 EDT
Description of problem:
I had a comment in my build section: 
# During the build obviously we can just write to %{buildroot}...

[fm@thinkpad SPECS]$ rpmlint adempiere.spec
adempiere.spec:142: W: rpm-buildroot-usage %build # During the build obviously we can just write to %{buildroot}...

It was obviously at the wrong place, nevertheless, rpmlint should not complain about words I use in comments ...

Version-Release number of selected component (if applicable):
[fm@thinkpad SPECS]$ rpm -q rpmlint
rpmlint-0.95-2.fc12.noarch


How reproducible:
allways
Comment 1 Ville Skyttä 2010-03-31 13:41:04 EDT
The rpm-buildroot-usage check doesn't indeed make much sense for commented out things, fixed upstream.

However, future rpmlint versions _will_ intentionally warn about all unescaped macros in shell comments because shell comments may not cancel their effect, see bug 571375.
Comment 2 Ville Skyttä 2010-04-21 18:01:11 EDT
Done in 0.96-1 in Rawhide, F-12+ will follow sometime soonish.
Comment 3 Fedora Update System 2010-05-18 16:21:11 EDT
rpmlint-0.97-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rpmlint-0.97-1.fc13
Comment 4 Fedora Update System 2010-05-18 16:22:20 EDT
rpmlint-0.97-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.97-1.fc12
Comment 5 Fedora Update System 2010-05-19 15:16:10 EDT
rpmlint-0.97-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/rpmlint-0.97-1.fc13
Comment 6 Fedora Update System 2010-05-28 14:04:00 EDT
rpmlint-0.97-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-06-04 14:47:00 EDT
rpmlint-0.97-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.