Bug 57854 - "EXT3-fs error" "attempt to access beyond end of device"
"EXT3-fs error" "attempt to access beyond end of device"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-28 08:35 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-28 08:35:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
I have File System problem with avec  RH 7.2, kernel 2.4.7-10 for few days.

Symptom on console are described bellow :

Dec 10 19:08:59 poudlard syslogd 1.4.1: restart.
Dec 10 19:09:50 poudlard kernel: attempt to access beyond end of device
Dec 10 19:09:50 poudlard kernel: 03:02: rw=0, want=1506635160,
limit=4096575
Dec 10 19:09:50 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #66209 contains a hole at offset 0
Dec 10 19:09:50 poudlard kernel: attempt to access beyond end of device
Dec 10 19:09:50 poudlard kernel: 03:02: rw=0, want=1360852344,
limit=4096575
Dec 10 19:09:50 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #66209 contains a hole at offset 4096
Dec 10 19:09:50 poudlard kernel: attempt to access beyond end of device
Dec 10 19:09:50 poudlard kernel: 03:02: rw=0, want=1093960028,
limit=4096575
Dec 10 19:09:50 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #66209 contains a hole at offset 8192
Dec 10 19:09:50 poudlard kernel: attempt to access beyond end of device
Dec 10 19:09:50 poudlard kernel: 03:02: rw=0, want=1286937880,
limit=4096575
Dec 10 19:09:50 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #66209 contains a hole at offset 12288

10 minutes after, computer hang.

I am obliged to powe off the computer and run fsck manually which is very
damageous for file system.

When this error messages appear , it s always, 5 or 6 minute after a boot.

Hard disk drive is an IBM 20 Go on wich is install
a dual boot with windows 98.

Before the same disk was used with redhat 6.2 without any probleme.

Recently, i have upgrade my kernel via RHN , i am now :

 2.4.9-13 #1 Tue Oct 30 19:32:27 EST 2001 i686 unknown

Unfortunaltly , problem occur again with the new kernel yesterday :

Dec 27 08:48:40 poudlard kernel: attempt to access beyond end of device
Dec 27 08:48:40 poudlard kernel: 03:02: rw=0, want=1838527880,
limit=4096575
Dec 27 08:48:40 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #49217 contains a hole at offset 0
Dec 27 08:48:40 poudlard kernel: attempt to access beyond end of device
Dec 27 08:48:40 poudlard kernel: 03:02: rw=0, want=1970640276,
limit=4096575
Dec 27 08:48:40 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: directory #49217 contains a hole at offset 4096
Dec 27 08:48:40 poudlard kernel: attempt to access beyond end of device
Dec 27 08:48:40 poudlard kernel: 03:02: rw=0, want=554480996, limit=4096575
Dec 27 08:48:40 poudlard kernel: EXT3-fs error (device ide0(3,2)):
ext3_readdir: d
....

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Shutdown computer
2.boot
3.wait 5 or 6 minutes and sometimes pb appear ( about 1/10 )
	

Actual Results:  - I hear the disk working :)
- /var/log/message are very verbose
- Computer hang then minute after, i am oblige to power down system


Expected Results:  No noise messages, normal behaviour, no hang


Additional info:
Comment 1 Need Real Name 2001-12-28 08:39:24 EST
- This bug is similar to  56045 which is closed without solution.

- HW processor is : cpu: AMD Athlon(tm) Processor 650MHz
Comment 2 Need Real Name 2001-12-28 09:02:29 EST
Hard Drive  is  :
IBM  DPTA-372050  20.52 GB  IDE  7200 RPM
Comment 3 Arjan van de Ven 2002-01-25 04:24:31 EST
Hmm this looks like either a hardware problem or a nasty interaction with
hardware ;(
Comment 4 Alan Cox 2003-06-07 19:58:55 EDT
Seems to be the VIA chipset flaw, which was worked around by later kernels.
CLosing on that basis

Note You need to log in before you can comment on or make changes to this bug.