Bug 578582 - [abrt] crash in ksh-20100309-1.fc12: Process /bin/ksh was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in ksh-20100309-1.fc12: Process /bin/ksh was killed by signal 11...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ksh
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:25d95182032d674a5edde86fbda...
: 570293 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-31 17:41 UTC by Jeff Frontz
Modified: 2010-05-31 18:28 UTC (History)
2 users (show)

Fixed In Version: ksh-20100309-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 18:13:57 UTC


Attachments (Terms of Use)
File: backtrace (5.84 KB, text/plain)
2010-03-31 17:41 UTC, Jeff Frontz
no flags Details

Description Jeff Frontz 2010-03-31 17:41:01 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: -ksh
comment: Note that this isn't easily reproducible, but it's happened several times (including on the previous FC12 release of ksh).
component: ksh
executable: /bin/ksh
kernel: 2.6.32.9-70.fc12.x86_64
package: ksh-20100309-1.fc12
rating: 4
reason: Process /bin/ksh was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. cd'd deep into a remote directory (via /net).
2. cd'd up the directory tree (but still in the remote side -- under /net)
3. cd'd up again (and again still in the remote side of things) and BOOM, shell crashed

Comment 1 Jeff Frontz 2010-03-31 17:41:02 UTC
Created attachment 403794 [details]
File: backtrace

Comment 2 Michal Hlavinka 2010-04-01 10:50:55 UTC
*** Bug 570293 has been marked as a duplicate of this bug. ***

Comment 3 Michal Hlavinka 2010-04-01 16:44:55 UTC
After looking into backtrace, I've found only one possibility shp==null, but this is required for almost everything in ksh, so it's also hard to believe. I've forwarded this issue to upstream. Waiting for their response.

Anyway, if you find some more reliable reproducer, please let me know. I've tried a lot of things, but no crash.

Comment 4 Michal Hlavinka 2010-04-06 15:03:06 UTC
Upstream has suggested the fix. I've prepared packages with that patch, could you please test if it fixes this bug for you or if you can still reproduce this bug with this ksh build?

Packages can be found here:

http://koji.fedoraproject.org/koji/getfile?taskID=2097301&name=ksh-20100309-3.fc12.1.bz578582.x86_64.rpm

http://koji.fedoraproject.org/koji/getfile?taskID=2097301&name=ksh-debuginfo-20100309-3.fc12.1.bz578582.x86_64.rpm

Comment 5 Michal Hlavinka 2010-04-08 07:18:37 UTC
I've put these testing rpms here : http://mhlavink.fedorapeople.org/ because koji would remove them soon. Please let me know once you've tested them.

Comment 6 Jeff Frontz 2010-04-08 15:37:01 UTC
I've downloaded it and been running on it for a little over a day.  So far, no news-- however, reproducing the bug has been kind of hit-and-miss in the past.

Comment 7 Michal Hlavinka 2010-04-09 06:39:57 UTC
thanks, I'll report upstream that it works if nothing happens till Tuesday

Comment 8 Michal Hlavinka 2010-04-13 14:52:03 UTC
I've emailed upstream that you did not reproduced this bug with patched ksh so far. I'm waiting for their response, thend I'll do a proper fix.

Comment 9 Fedora Update System 2010-05-05 12:51:45 UTC
ksh-20100309-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ksh-20100309-5.fc13

Comment 10 Fedora Update System 2010-05-05 13:03:05 UTC
ksh-20100309-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ksh-20100309-5.fc12

Comment 11 Fedora Update System 2010-05-05 13:03:06 UTC
ksh-20100309-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ksh-20100309-5.fc11

Comment 12 Fedora Update System 2010-05-06 03:38:31 UTC
ksh-20100309-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-5.fc12

Comment 13 Fedora Update System 2010-05-06 03:40:49 UTC
ksh-20100309-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-5.fc11

Comment 14 Fedora Update System 2010-05-06 03:42:35 UTC
ksh-20100309-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-5.fc13

Comment 16 Fedora Update System 2010-05-31 18:13:47 UTC
ksh-20100309-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-05-31 18:23:25 UTC
ksh-20100309-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-05-31 18:28:03 UTC
ksh-20100309-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.