Bug 57870 - IPv6 reverse IP queries incorrectly formatted
Summary: IPv6 reverse IP queries incorrectly formatted
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-29 16:35 UTC by Russell King
Modified: 2016-11-24 15:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-29 16:35:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell King 2001-12-29 16:35:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
With glibc 2.2.2, IPv6 reverse queries are formatted correctly, according
to RFC1886:
    a.b.c.d.e.f.g.h.i.j.(etc).ip6.int.
With glibc 2.2.4, IPv6 reverse queries are formatted differently:
    a.b.c.d.e.f.g.h.i.j.(etc).ip6.arpa.
which meets neither RFC1886 nor RFC2874.  RFC1886 mandates the use of the
nibble based .ip6.int. domain, where as RFC2874 mandates the use of
\[xprefix/length].ip6.arpa. bitstring queries.

Therefore, glibc 2.2.4-based systems are unable to perform any IPv6 reverse
IP queries.

Note also that RFC2874 recommends that the old RFC1886 method is tried in
addition - this seems to be a sensible idea since the .ip6.arpa domain
appears to be currently empty.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup two ipv6 hosts with RFC1886 and RFC2874-compliant nameserver PTR
records.
2. login over ssh from one host to the other host.
3. netstat
4. host <ipv6 address>
	

Actual Results:  netstat returns only numeric addresses
host returns a valid name record.

Expected Results:  netstat should display the name.

Additional info:

bind 9.1.0-10 used.
glibc 2.2.2 works correctly, sending RFC1886 compliant PTR requests.

Comment 1 Pekka Savola 2002-01-17 14:18:21 UTC
Only ip6.int nibble-based structure was moved under ip6.arpa.  Conversion
to bitstring labels was not intended by the BCP document.   This has been
clarified
by the author of the draft.



Note You need to log in before you can comment on or make changes to this bug.