Bug 57877 - Okipage8z does not work under RH7.2 & foomatic 1-1-0.20010905.1
Okipage8z does not work under RH7.2 & foomatic 1-1-0.20010905.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-30 08:47 EST by JP Tham
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-30 08:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JP Tham 2001-12-30 08:47:48 EST
Description of Problem: 
I installed RH7.2 recently and have never being able to get the OkiPage8z 
with both parallel and USB ports printing anything from RH7.2. 
The printer was configured as a local printer at /dev/lp0 and 0ki4w was the 
driver specified. Apparently, the printer was also detected at  /dev/usb/lp0.
I was able to define a print queue 'Oki' and send test pages to it. However 
the jobs failed and was removed without any thing being printed. The printer 
remained "idle and accepting jobs" after the jobs failed and were removed

The error is as follows:
": prepended:' at 2001-12-30-12:21:05.563 ## A=<NULL> number=534 
process=4567
IF filter 'mf_wrapper' filter msg - 'gs  PID pid2=4579' at 
2001-12-30-12:21:05.564 ## A=<NULL> number=534 process=4567
IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at 
2001-12-30-12:21:05.566 ## A=<NULL> number=534 process=4567
IF filter 'mf_wrapper' filter msg - 'sh: /dev/oki4drv: Permission denied' at 
2001-12-30-12:21:05.573 ## A=<NULL> number=534 process=4567
IF filter 'mf_wrapper' filter msg - 'tail process done writing data to 
*main::STDOUT' at 2001-12-30-12:21:05.574 ## A=<NULL> number=534 
process=4567
IF filter 'mf_wrapper' filter msg - 'Error closing pipe to (echo -en "%FAKEOKI 
PAPERSIZE=letter\n%FAKEOKI MANUALFEED=OFF\n%FAKEOKI 
PAPERWEIGHT=0\n%FAKEOKI DARKNESS=0\n%FAKEOKI 
GRAPHICS=OFF\n"; cat) 1>/dev/oki4drv 2>/dev/null at 
/usr/share/printconf/util/printconf_mfomatic.pl line 397, <STDIN> line 284.' at 
2001-12-30-12:21:05.578 ## A=<NULL> number=534 process=4567
IF filter 'mf_wrapper' filter exit status 'JFAIL' at 2001-12-30-12:21:05.585 ## 
A=<NULL> number=534 process=4567
printing finished at 2001-12-30-12:21:05.585 ## A=<NULL> number=534 
process=4567
accounting at end at 2001-12-30-12:21:05.585 ## A=<NULL> number=534 
process=4567
finished 'cfA534mcns11.docsis119.singa.pore.net', status 'JFAIL' at 
2001-12-30-12:21:05.585 ## A=<NULL> number=534 process=4567
subserver pid 4567 exit status 'JFAIL' at 2001-12-30-12:21:05.586 ## 
A=<NULL> number=0 process=4535
job 'cfA534mcns11.docsis119.singa.pore.net', attempt 3, allowed 3 at 
2001-12-30-12:21:05.587 ## A=<NULL> number=534 process=4535
send_failure_action 'JREMOVE' at 2001-12-30-12:21:05.587 ## A=<NULL> 
number=534 process=4535
job 'cfA534mcns11.docsis119.singa.pore.net', removing job - status JREMOVE 
at 2001-12-30-12:21:05.587 ## A=<NULL> number=534 process=4535
removing job 'cfA534mcns11.docsis119.singa.pore.net' - JREMOVE at 
2001-12-30-12:21:05.588 ## A=<NULL> number=534 process=4535"




Version-Release number of selected component (if applicable):
foomatic 1-1-0.20010905.1

How Reproducible:
Have reinstall a few times with usb port disabled at motherboard level, with 
both USB and parallel ports connected at the same time as well as with 
parael port connected only. TRied lpr textfile, printing from Netscape, 
spreadsheet etc. Not a single print-job was sucessful.

Steps to Reproduce:
1. as described above
2. 
3. 

Actual Results:
Absolutely nothing printed

Expected Results:
Ascii or postscript, jpg test pages etc printed

Additional Information:
 I have Windows as a dual-boot OS and the Oki prints well under Windows.
My computer config: 
AMD Athalone 600MHz, 392MB memory. 20MB Quantum, Riva TNT video, 
Hyundai Deluxscan 15G+ monitor,50X CDRom, a Creative CDRW and of 
course the Okipage8z. Cable modem connected to the Internet.
Comment 1 JP Tham 2002-01-01 08:26:34 EST
Problem was due to permission of /dev/oki6drv being somehow set during
installation to 550 root/root. Printing works after chmod to relax the
permission.

Note You need to log in before you can comment on or make changes to this bug.