Bug 579057 - [abrt] crash in desktop-effects-0.8.4-3.fc13: Process /usr/bin/desktop-effects was killed by signal 11 (SIGSEGV)
[abrt] crash in desktop-effects-0.8.4-3.fc13: Process /usr/bin/desktop-effect...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:a4a038e19c24440ef46ab8e7b35...
:
: 539402 579340 582858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 07:57 EDT by Lucian Langa
Modified: 2010-04-23 04:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 04:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (8.38 KB, text/plain)
2010-04-02 07:57 EDT, Lucian Langa
no flags Details

  None (edit)
Description Lucian Langa 2010-04-02 07:57:08 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: desktop-effects
component: desktop-effects
executable: /usr/bin/desktop-effects
kernel: 2.6.33.1-19.fc13.x86_64
package: desktop-effects-0.8.4-3.fc13
rating: 3
reason: Process /usr/bin/desktop-effects was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.start the aplication from the menu
2.
3.
Comment 1 Lucian Langa 2010-04-02 07:57:10 EDT
Created attachment 404173 [details]
File: backtrace
Comment 2 Jeff Raber 2010-04-16 01:47:04 EDT
*** Bug 582858 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Raber 2010-04-16 02:08:53 EDT
Do you have the NVIDIA binary drivers installed?  
What does 'stat -c %N /usr/lib64/libGL.so.1' show?  
Do you get the same crash after running/closing 'glxgears'?
Comment 4 Lucian Langa 2010-04-16 14:10:30 EDT
Yes indeed, I had some leftovers from a previous nvidia driver installation.
libGL.so.1 was pointing to nvidia's libGL but shoudn't mesa-libGL upgrade overwrite this ? yum reinstall does not overwrite either.
Strangely glxgears was working.
Anyway it seems to work now after deleting leftovers.
Comment 5 Jeff Raber 2010-04-16 18:31:39 EDT
'yum reinstall' did not fix it for me either.  I even tried deleting the symlink, then running 'yum reinstall' only to have the symlink recreated pointing to NVIDIA's libGL.so.1

'rpm -V mesa-libGL.x86_64' returns '....L....    /usr/lib64/libGL.so.1' which acknowledges that the symlink has been modified.  (The 'L' meaning "readLink(2) path mismatch") My final solution was to manually modify the link to point to `/usr/lib64/libGL.so.1.2'.
Comment 6 Jeff Raber 2010-04-21 10:47:15 EDT
*** Bug 579340 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Raber 2010-04-21 10:54:31 EDT
*** Bug 539402 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Raber 2010-04-23 04:33:39 EDT
Closing as CANTFIX as this seems to be caused by the NVIDIA binary driver.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the same problem may be able to assist.  If there is a real bug occurring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.