Bug 579340 - [abrt] crash in desktop-effects-0.8.4-2.fc12: Process /usr/bin/desktop-effects was killed by signal 11 (SIGSEGV)
[abrt] crash in desktop-effects-0.8.4-2.fc12: Process /usr/bin/desktop-effect...
Status: CLOSED DUPLICATE of bug 579057
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:1dd32ecf91336194a645157774b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-04 06:20 EDT by bugzilla
Modified: 2010-04-21 10:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 10:47:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.72 KB, text/plain)
2010-04-04 06:20 EDT, bugzilla
no flags Details

  None (edit)
Description bugzilla 2010-04-04 06:20:07 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: desktop-effects
component: desktop-effects
executable: /usr/bin/desktop-effects
kernel: 2.6.32.10-90.fc12.x86_64
package: desktop-effects-0.8.4-2.fc12
rating: 3
reason: Process /usr/bin/desktop-effects was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
Click on desktop-effects
2.
3.
Comment 1 bugzilla 2010-04-04 06:20:09 EDT
Created attachment 404382 [details]
File: backtrace
Comment 2 bugzilla 2010-04-04 06:32:40 EDT

How to reproduce
-----
Click on desktop-effects
2.
3.
Comment 3 Jeff Raber 2010-04-16 02:13:06 EDT
This issue appears to be caused by installing the NVIDIA binary drivers.  The NVIDIA installer modifies the symlink '/usr/lib64/libGL.so.1' making it point to their (apparently broken) version of that .so file.

Do you get the same crash after running 'glxgears'?

The following resolved this crash for me:
1. Ensure X is using the nouveau driver (not the NVIDIA binary blob) 'sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak'
2. 'sudo rm /usr/lib64/libGL.so.1'
3. 'sudo ln -s /usr/lib64/libGL.so.1.2 /usr/lib64/libGL.so.1'
Comment 4 Jeff Raber 2010-04-21 10:47:15 EDT

*** This bug has been marked as a duplicate of bug 579057 ***

Note You need to log in before you can comment on or make changes to this bug.