This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57948 - up2date fails with 404 file not found
up2date fails with 404 file not found
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-02 17:58 EST by Need Real Name
Modified: 2015-01-07 18:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 09:11:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-02 17:58:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When running up2date on my system, I get the following:

Getting headers for available packages...
There was a fatal error communicating with the server.  The message was:
404: "Not Found" while attempting to get 
$RHN/redhat-linux-i386-7.1/getPackageHeader/devfsd-2.4.3-12.i386.hdr

It looks to me like a file on your server is missing. This causes the 
entire up2date system to fail.

Version-Release number of selected component (if applicable):
up2date-2.7.11-7.x.1

How reproducible:
Always

Steps to Reproduce:
1. Run rhn_register
2. Add PGP key to keyring
3. Run "up2date -l" or any other up2date command.
	

Actual Results:  Getting headers for available packages...
There was a fatal error communicating with the server.  The message was:
404: "Not Found" while attempting to get 
$RHN/redhat-linux-i386-7.1/getPackageHeader/devfsd-2.4.3-12.i386.hdr

Expected Results:  It should have listed the packages needed for update.

Additional info:

It's pretty easy to reproduce. You should be able to verify on your 
systems.
Comment 1 Adrian Likins 2002-01-07 18:29:28 EST
This was a server side issue. It should be resolved now.
Comment 2 Need Real Name 2002-03-22 13:22:46 EST
I just reloaded my laptop yesterday with RedHat 7.2 and this error started
occuring. I tried upgrading to the newest up2date RPM, but the error is still
occuring.
Comment 3 Jay Turner 2002-03-22 14:23:05 EST
Actually, the issue is back and we know about it.  We are working to resolve it
right now.
Comment 4 Matt Osmus 2002-03-22 15:51:35 EST
Just FYI, I just loaded 7.2 on a new machine, and ran up2date. Exact same 
problem as stated above, but with error:

"There was a fatal error communicating with the server. The message was:
404: "Not Found" while attempting to get
$RHN/redhat-linux-i386-7.2/getPackageHeader/rhn_register-gnome-2.7.2-7.x.8.i386.hdr"
Comment 5 Josh Treece 2002-04-10 13:53:16 EDT
Hi,  Just loaded a new install of 7.2 on a laptop, ran up2date and got a 404 -
not found error when getting headers of glibc-devel-2.2.4-19.3.i386.hdr

so, up2date fails there...  when will the files return?
Comment 6 Adrian Likins 2002-04-10 15:06:25 EDT
the glibc 404's were a temporary server side error. Should be fixed now.
Comment 7 Need Real Name 2002-04-12 01:15:06 EDT
I just installed RH 7.2 on a desktop and I got the error. I even updated up2date
and I still get it....

Comment 8 Need Real Name 2002-04-12 01:22:29 EDT
Oh, I got this error:

"
There was a fatal error communicating with the server. The message was:
404: "Not found" while attempting to get
$RHN/redhat-linux-i386-7.2/getPackageHeader/rhn_register-2.7.9-7.x.2.i386.hdr
"
Comment 9 Adrian Likins 2002-04-12 14:20:23 EDT
Just for future reference for folks reading this bug, anytime you
get a 404 error, there is something wrong with the server. 

If you get a 404, it is a server side error. And it's almost
always something new. So in a way, it's probabaly best to open
a new bug report. Or just add on it here, I guess it doesnt really
hurt anything. Just makes it awfully hard to ever actually close
the bug ;->

Just wanted to make the point that this is only kind of the
same bug for each of these reports.
Comment 10 Mihai Ibanescu 2002-04-12 14:49:27 EDT
Can you please check? This should be fixed by now.
Comment 11 Need Real Name 2002-05-15 12:57:23 EDT
I am getting this error sporatically. Sometimes I get it as soon as I try to connect, other times I get as far as finding all relevant packages, selecting which files to install in the Netscape window and then having it crash. I've not been able to complete the update in about 20 tries in the last 3 hours... 

I thought it was fixed since the last bug report was over a month ago, but apparently it isn't... Any suggestions?
Comment 12 Adrian Likins 2002-05-15 15:05:15 EDT
Since this is a server side error, I need to know specifically what
404's you are getting.
Comment 13 Jay Turner 2003-02-14 09:11:02 EST
Haven't seen issues like this in quite some time.
Comment 14 Thomas Drottvik 2003-05-24 12:28:27 EDT
I got this on my RH 7.3 system, this is the output:
[root@lkpue23 cron.hourly]# up2date -l

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
404: "Not Found" while attempting to get 
$RHN/redhat-linux-i386-7.3/getPackageHeader/pam-devel-0.75-46.7.3.i386.hdr


So is there some trouble on the server

Note You need to log in before you can comment on or make changes to this bug.