Bug 57958 - Address not released on 'ifdown' when using dhcpcd
Address not released on 'ifdown' when using dhcpcd
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-03 08:00 EST by Toralf
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 08:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2002-01-03 08:00:50 EST
Description of Problem:
To make a long story short, I think line 77 of /sbin/ifdown should be
changed from
		kill `cat /var/run/dhcpcd-${DEVICE}.pid`
to
		kill -HUP `cat /var/run/dhcpcd-${DEVICE}.pid`

Version-Release number of selected component (if applicable):
6.40-1
Comment 1 Toralf 2002-04-18 08:39:56 EDT
Note that the signal handling has changed somewhat in dhcpcd-1.3.21, so SIGHUP
may no longer be necessary on normal reboot. I guess you should review the
sources code in order to figure out what to do.
Comment 2 Bill Nottingham 2002-11-12 00:19:11 EST
See bug 46942 for the reasoning here.

Note You need to log in before you can comment on or make changes to this bug.