Bug 57971 - Custom ks cdrom fails finding bg5ps pkg
Summary: Custom ks cdrom fails finding bg5ps pkg
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-03 21:02 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 20:26:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback...machine state (70.17 KB, text/plain)
2002-01-07 18:21 UTC, Need Real Name
no flags Details
create CD script file (1.58 KB, text/plain)
2002-01-17 18:25 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-01-03 21:02:07 UTC
Description of Problem:I'm attempting to create a single "kickstart" cdrom 
for redhat 7.2 on a gateway model gp7-450 pc. after successfully creating 
the cdrom I installed it into the pc. the system boots up ok and the   
anaconda installer starts, followed by  "searching for packages" window. 
at this point the system halts and the following message is displayed: "an 
unhandled exception has occurred. this is most likely a bug". 
Traceback <innermost last>:
File "/usr/bin/anaconda", line 620, in ?
      intf.run<id, dispatch, configFileData>
File "/usr/lib/anaconda/text.py" line 408, in gotoNext
      dispatch.gotoNext<>
Several more lines like the above are displayed follwed by:
KeyError:bg5ps

I saved the machine state to "floppy" (as suggested via displayed message) 
which can be uploaded if needed.
 


Version-Release number of selected component (if applicable):


How Reproducible:easily 

Steps to Reproduce:
1. make a kickstart cdrom and run it
2. install in a pc that supports "bootable cdrom" 
3. power on pc and observe system behavior

Actual Results:system halts with above error messages


Expected Results:redhat 7.2 O/S packages to load


Additional Information:

Comment 1 Jeremy Katz 2002-01-04 03:17:45 UTC
Yes, the full traceback as well as the kickstart file would be very helpful

Comment 2 Need Real Name 2002-01-07 18:21:23 UTC
Created attachment 41951 [details]
traceback...machine state

Comment 3 Brent Fox 2002-01-07 20:34:44 UTC
Here's the kickstart file I received via email:

lang en_US

langsupport --default en_US

cdrom

#device scsi sym53c8xx

keyboard us

bootloader --useLilo

#--location=mbr

zerombr yes

clearpart --all

part / --size 750
part /boot --size 10
part swap --size 500
part /tmp --size 1000
part /var --size 1500
part /usr --size 1000
part /home --size 1000 --grow

install
#upgrade

mouse genericps/2

timezone --utc UTC

#xconfig  --server "ATI Mach64 --monitor "Generic04"
skipx

text

rootpw secure.hnl

auth --useshadow

#lilo --location mbr

#interactive

firewall --disabled

%packages
@ GNOME
@ Graphics and Image Manipulation
@ Windows Compatibility / Interoperability
@ Network Managed Workstation
@ Software Development
#make
#mkkickstart
#pdksh
#xinetd
#sndconfig
#xntp3
#ucd-snmp
#ucd-snmp-utils
#
%post --nochroot
#!/bin/bsh
#
#
# Perform final install changes for SCSI driver
#cp /mnt/source/safa/modules.cgz /mnt/sysimage/tmp/modules.cgz
#cp /mnt/source/safa/script2 /mnt/sysimage/tmp/script2
#chmod 700 /mnt/sysimage/tmp/script2
#chroot /mnt/sysimage /tmp/script2
#
#
#Perform initial post install actions to configure Linux
cp /mnt/source/safa/post1.bash /mnt/sysimage/tmp/post1.bash
chmod 700 /mnt/sysimage/tmp/post1.bash
chroot /mnt/sysimage /tmp/post1.bash
#
#
#Retrieve SAFA specific install script
cp /mnt/source/safa/copy_cd.bash /mnt/sysimage/tmp/copy_cd
chmod 700 /mnt/sysimage/tmp/copy_cd
chroot /mnt/sysimage mv /tmp/copy_cd /root/copy_cd
#
#
#Retrieve SAFA specific install script
cp /mnt/source/safa/install_safa.bash /mnt/sysimage/tmp/install_safa
chmod 700 /mnt/sysimage/tmp/install_safa
chroot /mnt/sysimage mv /tmp/install_safa /usr/bin/install_safa
#
#end of script

Comment 4 Brent Fox 2002-01-07 20:36:29 UTC
I'm confused because the traceback looks like the machine was doing an upgrade,
but the kickstart file is set to do an install instead of an upgrade.  The line
for upgrade has been commented out of the kickstart file.  Were you intending to
do an upgrade or a full install?

Comment 5 Need Real Name 2002-01-08 15:01:37 UTC
response to comments from bfox@redhat.com concerning the kickstart file. the  
intent is to do an install, not an upgrade. i had completed an initial install 
of 7.2 and my first try at the kickstart i inserted "upgrade" and "interactive" 
as the method to install. my thinking was that this method would preserve files 
already installed and allow me to single step through the install process for 
the first time. since i made several attempts at the installation i suspect 
that the traceback file may reflect the upgrade attempt. please be advised 
that "upgrade" , or "full install" caused a similar failure    


Comment 6 Michael Fulbright 2002-01-16 19:33:18 UTC
How did you create the CD image you are using? Is the bg5ps package on the CD?

Comment 7 Need Real Name 2002-01-17 18:25:55 UTC
Created attachment 42734 [details]
create CD script file

Comment 8 Need Real Name 2002-01-18 20:26:40 UTC
please be advised that bg5ps pkg is part of the Applications/Publishing Group

sorry for omitting this info in the previous request

Comment 9 Brent Fox 2002-01-18 20:34:09 UTC
Yes, the bg5ps RPM is a part of the distro, but the traceback message you are
seeing suggests that the installer is looking for that package on the cd and
it's not finding it.  Can you take that cd to another machine and try to install
the bg5ps RPM from it?  I think you will find that the RPM either isn't there,
or is corrupted somehow.


Note You need to log in before you can comment on or make changes to this bug.