Bug 57973 - Squid doesn't work with config directive cache_peer
Squid doesn't work with config directive cache_peer
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: squid (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-03 16:48 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 09:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-03 16:48:46 EST
Description of Problem:

I have squid problem. If I want to configure squid to send requests to 
another squid proxy server then i can't access secure site (https). Normal 
sites mostly do OK.

Version-Release number of selected component (if applicable):
squid-2.4.STABLE1-6


How Reproducible:
Every time I want to access https sites. I have tried on several machines.

Steps to Reproduce:
1. Configure squid with 
cache_peer proxy.xxxx.sss parent 3128 0 no-query proxy-only
prefer_direct off
This are most important configuration lines in squid.conf file.

2. Try to access https site over this proxy
3. 

Actual Results:
Don't get any response from squid

Expected Results:
Connection to https sites should work wery well.

Additional Information:
If you need more information please contact me at my email.
Comment 1 Reuben Farrelly 2002-01-27 02:53:09 EST
Other important configuration lines are  always_direct and never_direct.
I'm sure it is not a bug with the Redhat RPM as I have been using these RPM's 
for many months now in a production environment and cannot replicate this 
problem.

Have you tried the latest release from 
ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/squid-
2.4.STABLE2-4.i386.rpm   ??
You may also want to look for advice on the squid-users@squid-cache.org mailing 
list:  http://www.squid-cache.org/Doc/FAQ/FAQ-1.html#ss1.9
Comment 2 Need Real Name 2002-01-28 04:25:20 EST
When you want to work Squid as proxy to proxy connections (cache_peer) squid do 
corectly all unsecured (http) connections but all secured (https) connection 
goes direct (allways).
Comment 3 Martin Stransky 2005-08-29 10:39:53 EDT
Have you checked the new versions of squid?

Note You need to log in before you can comment on or make changes to this bug.