Bug 5799 - 6.0 static network kickstart file doesn't work under 6.1
6.0 static network kickstart file doesn't work under 6.1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 02:47 EDT by peter-redhat
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 15:41:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter-redhat 1999-10-10 02:47:18 EDT
I have a kickstart file that works fine under redhat 6.0.
I am trying it with 6.1 and there are no changes in the
format (that I can find documented) and there are several
things that don't work (as far as I can tell).

It doesn't look like the kickstart parser (in the .py file)
recognizes the static keyword - it always uses DHCP (and
fails)

Here's the line that works with rh6.0 kickstart

network --bootproto STATIC --ip 192.168.1.1 --netmask
255.255.255.0

Additionally I get an error on the follwoing line (the goal
of which is to say I don't have a mouse on this firewall box
I am building and please don't probe)

mouse --kickstart --noprobe none

For now, I will just keep using redhat 6.0 and applying the
Errata but if I am doing anything wrong, I'd appreciate
help. If these are real bugs then it would be great if they
could be fixed.

By the way, the "static" config dumped by "mkkickstart"
still has the incorrect "__static" keyword in it.
Comment 1 Cord Kielhorn 1999-10-20 09:56:59 EDT
Have you tried "--bootproto static" (with lowercase letters)?
Works for me.
Comment 2 Cord Kielhorn 1999-10-20 16:41:59 EDT
Have you tried "--bootproto static" (with lowercase letters)?
Works for me.
Comment 3 Jay Turner 1999-10-21 12:32:59 EDT
We are in the process of putting together a fix for this problem.  We
should be releasing a fix the week of October 18th.
Comment 4 Jay Turner 1999-10-21 14:26:59 EDT
*** Bug 5952 has been marked as a duplicate of this bug. ***

I setup a boot floppy with a ks.cfg on it to test kickstart
installs.  I typed "linux ks=floppy" when I booted the
floppy, and it booted the system, but it tried to get it's
IP address from DHCP instead of using what was specified in
the ks.cfg file.  This works with RH 6.0.


Mike Iglesias
University of California, Irvine
iglesias@uci.edu
Comment 5 Jay Turner 1999-10-25 13:20:59 EDT
*** Bug 6340 has been marked as a duplicate of this bug. ***

Added a %pre scripting section

- Found the following bugs :

When assigning a static ip it still wants to grab a dhcp
address.

The documentation needs to be updated within the manual,
there is no documentation on how to extend the kickstart
with python as said in the new features section.
Comment 6 Jay Turner 2000-02-11 15:41:59 EST
This issue is resolved in the latest installer available in beta.

Note You need to log in before you can comment on or make changes to this bug.