Bug 5800 - Lacking routines in lapack-3.0-1
Lacking routines in lapack-3.0-1
Status: CLOSED ERRATA
Product: Red Hat Powertools
Classification: Retired
Component: lapack (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 04:40 EDT by Joachim Frieben
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-19 05:47:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 1999-10-10 04:40:27 EDT
During the builing of the package lapack-3.0-1 many routines
seem to have been omitted (compilation has probably aborted
for these ones). The concerned routines are:

> cgelsd
> cgelsy
> cgeqp3
> cgesc2
> cgesdd
> cgetc2
> cgges
> cggesx
> cggev
> cggevx
> cgtts2
> chbgvd
> chbgvx
> cheevr
> chegvd
> chegvx
> chpgvd
> chpgvx
> clacp2
> clals0
> clalsa
> clalsd
> claqp2
> claqps
> clar1v
> clarcm
> clarrv
> clarz
> clarzb
> clarzt
> clatdf
> clatrz
> cptts2
> cstegr
> ctgex2
> ctgexc
> ctgsen
> ctgsna
> ctgsy2
> ctgsyl
> ctzrzf
> cunmr3
> cunmrz
> dbdsdc
> dgelsd
> dgelsy
> dgeqp3
> dgesc2
> dgesdd
> dgetc2
> dgges
> dggesx
> dggev
> dggevx
> dgtts2
> dlagv2
> dlals0
> dlalsa
> dlalsd
> dlaqp2
> dlaqps
> dlar1v
> dlarrb
> dlarre
> dlarrf
> dlarrv
> dlarz
> dlarzb
> dlarzt
> dlasd0
> dlasd1
> dlasd2
> dlasd3
> dlasd4
> dlasd5
> dlasd6
> dlasd7
> dlasd8
> dlasd9
> dlasda
> dlasdq
> dlasdt
> dlasq5
> dlasq6
> dlatdf
> dlatrz
> dormr3
> dormrz
> dptts2
> dsbgvd
> dsbgvx
> dspgvd
> dspgvx
> dstegr
> dstevr
> dsyevr
> dsygvd
> dsygvx
> dtgex2
> dtgexc
> dtgsen
> dtgsna
> dtgsy2
> dtgsyl
> dtzrzf
> lapack
> sbdsdc
> sgelsd
> sgelsy
> sgeqp3
> sgesc2
> sgesdd
> sgetc2
> sgges
> sggesx
> sggev
> sggevx
> sgtts2
> slagv2
> slals0
> slalsa
> slalsd
> slaqp2
> slaqps
> slar1v
> slarrb
> slarre
> slarrf
> slarrv
> slarz
> slarzb
> slarzt
> slasd0
> slasd1
> slasd2
> slasd3
> slasd4
> slasd5
> slasd6
> slasd7
> slasd8
> slasd9
> slasda
> slasdq
> slasdt
> slasq5
> slasq6
> slatdf
> slatrz
> sormr3
> sormrz
> sptts2
> ssbgvd
> ssbgvx
> sspgvd
> sspgvx
> sstegr
> sstevr
> ssyevr
> ssygvd
> ssygvx
> stgex2
> stgexc
> stgsen
> stgsna
> stgsy2
> stgsyl
> stzrzf
> zbcon
> zgelsd
> zgelsy
> zgeqp3
> zgesc2
> zgesdd
> zgetc2
> zgges
> zggesx
> zggev
> zggevx
> zgtts2
> zhbgvd
> zhbgvx
> zheevr
> zhegvd
> zhegvx
> zhpgvd
> zhpgvx
> zlacp2
> zlals0
> zlalsa
> zlalsd
> zlaqp2
> zlaqps
> zlar1v
> zlarcm
> zlarrv
> zlarz
> zlarzb
> zlarzt
> zlatdf
> zlatrz
> zptts2
> zstegr
> ztgex2
> ztgexc
> ztgsen
> ztgsna
> ztgsy2
> ztgsyl
> ztzrzf
> zunmr3
> zunmrz

EOF
Comment 1 Tim Powers 1999-11-22 09:03:59 EST
Reassigning bug.
Comment 2 Andrew Lumsdaine 1999-12-01 00:33:59 EST
FWIW, it seems that the problem may be due to a bug in the src distribution.  At
least, when I download the src rpm, there is a top-level Makefile.lapack that
seems to be broken in that it is missing the files listed as omitted above.  I
remade lapack from the src myself using the original lapack makefiles and
everything made just fine.  Of course, the original lapack makefiles are
themselves, if not quite broken, then somewhat primitive in the way they
consider and build the various libraries (e.g., naming the library lapack.a
rather than liblapack.a and the like).

If you are willing to help me put together an rpm for this I will be willing to
do the building and/or point out the specific problems with the existing src
makefiles.
Comment 3 Jeff Johnson 1999-12-03 09:13:59 EST
I am not sure how one goes about submitting a fix to bugzilla, so I am
just sending this to you since you are the "assigned to" for this bug.

I put together src and binary rpms that fix bug #5800.  You can
download them from

  http://www.lsc.nd.edu/~lums/lapack-3.0-2.src.rpm
  http://www.lsc.nd.edu/~lums/lapack-3.0-2.i386.rpm
  http://www.lsc.nd.edu/~lums/blas-3.0-2.i386.rpm
  http://www.lsc.nd.edu/~lums/blas-man-3.0-2.i386.rpm
  http://www.lsc.nd.edu/~lums/lapack-man-3.0-2.i386.rpm
Comment 4 Joachim Frieben 1999-12-19 05:47:59 EST
PROBLEM: During the building of the lapack-3.0-1.src.rpm, the Red Hat pro-
         vided makefiles Makefile.blas and Makefile.lapack that override
         the original ones have been adopted from version 2.0 without ANY
         modification. This was admissible for the BLAS routines where no
         change in the source distribution has occured. However, this is
         NOT the case for the LAPACK sources that have undergone substantial
         changes since version 2.0. Consequences hereof are:

             1/  Many new routines are not included in the makefile. They
                 are hence absent from the compiled libraries producing
                 linker errors complaining about lacking routines.

             2/  The shared object library version number has not been upda-
                 ted. It is still 2.0.1 though the source distribution has
                 moved to version 3.0.

RESOLUTION: update Makefile.lapack and Makefile.blas to take into account
            the changes in the source distribution as well as the move of
            the source version number to 3.0.

            10/23/99: build of lapack-3.0-2.src.rpm and the associated i386
                      binary RPMs with the updated makefiles. Extensive use
                      since that date has not revealed any further problem.
                      The shared object library version is 3.0.2.

            11/14/99: build lapack-3.0-3 to take into account the updated
                      source distribution as of 10/30/99 and available from
                      <ftp.netlib.org>. The shared object library version is
                      3.0.3.

            Source and binary RPMs have been uploaded to:

                      http://members.xoom.com/frieben/

Note You need to log in before you can comment on or make changes to this bug.