Bug 580101 - RFE: Add CLI option to provision a VM without starting it
RFE: Add CLI option to provision a VM without starting it
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 09:47 EDT by Charles Almond
Modified: 2010-05-05 15:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 15:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Almond 2010-04-07 09:47:24 EDT
Description of problem:
The current virt-install script always starts a newly provisioned VM.  virt-clone doesn't start a newly cloned VM, but to create a new VM with virt-install I would like to have a way to define the VM without actually starting it at the time it is defined.
Comment 1 Cole Robinson 2010-05-05 15:27:45 EDT
Thanks for the RFE, but this isn't something we can easily do in virt-install

For most installation scenarios we can't do what you want, because it's actually a two step process: fetch and/or configure the VM to boot from the install media, then configure the VM to boot from the HD. If we just define the guest and don't kick off the install step, your VM will require manual editting to no longer boot off the install CDROM, or PXE, or whatever.

So the best you are going to get here is the --no-reboot option. Sorry.

Note You need to log in before you can comment on or make changes to this bug.