Bug 580159 - "Shift" key appears stuck in VNC session F13 server/F12 viewer
"Shift" key appears stuck in VNC session F13 server/F12 viewer
Status: CLOSED DUPLICATE of bug 586406
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 11:34 EDT by Paul W. Frields
Modified: 2013-04-30 19:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 06:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of /usr/bin/xev activity (15.89 KB, text/plain)
2010-05-10 15:16 EDT, Paul W. Frields
no flags Details

  None (edit)
Description Paul W. Frields 2010-04-07 11:34:30 EDT
Description of problem:
"Shift" key appears stuck in VNC session on F13 VNC server.

Version-Release number of selected component (if applicable):
F13 server: tigervnc-1.0.90-0.8.20100219svn3993.fc13.x86_64
F12 viewer: tigervnc-1.0.0-3.fc12.x86_64

How reproducible:
Every time.  Reproduced using fresh account and VNC server on the F13 box.

Steps to Reproduce:
1. ssh <f13box> vncserver -geometry 1680x1050
2. vncviewer <f13box>:1
3. Shift key is stuck, drastically reducing functionality ('Enter' key in dialog boxes, arrow keys, etc.)
  
More information available up on request, if helpful.
Comment 1 Adam Tkac 2010-04-26 06:16:45 EDT
Would it be possible to retest this issue with the latest tigervnc packages, 1.0.90-0.9-20100420svn4030, from the updates-testing repo, please?

If it is still broken please run "/usr/bin/xev" utility inside vnc session and try to press some keys with/without shift and attach output & key sequence here, please.
Comment 2 Paul W. Frields 2010-04-26 07:14:43 EDT
The bug does not appear when using the vino server from within a GNOME session (i.e. port 5900).  It still appears when using the actual Xvnc port (5901), even under the new build 1.0.90-0.9-20100420svn4030.
Comment 3 Adam Tkac 2010-04-26 11:26:39 EDT
Previous Xvnc (1.0.90-0.9-20100420svn4030) was completely busted (bug #585930). Please retest this issue with the latest tigervnc-server-1.0.90-0.10.20100420svn4030.fc13. Thank you in advance.
Comment 4 Paul W. Frields 2010-04-26 20:36:22 EDT
Problem still occurring with 1.0.90-0.10.20100420svn4030.fc13.

When using the vino server from within a GNOME session on port 5900, no problems.  When using the Xvnc port 5901, keys act as if the Shift key is stuck.
Comment 5 Adam Tkac 2010-05-10 07:32:20 EDT
(In reply to comment #4)
> Problem still occurring with 1.0.90-0.10.20100420svn4030.fc13.
> 
> When using the vino server from within a GNOME session on port 5900, no
> problems.  When using the Xvnc port 5901, keys act as if the Shift key is
> stuck.    

Would it be possible to attach xev output, as written in comment #1, please? In my opinion this is same issue as bug #586406.
Comment 6 Paul W. Frields 2010-05-10 15:16:24 EDT
Created attachment 412940 [details]
Log of /usr/bin/xev activity

Typed Shift+a, Shift+b, Shift+c, a, b, c, Shift+Left, Shift+Left, Shift+Left, Left, Left, Left.
Comment 7 Adam Tkac 2010-05-13 06:14:34 EDT
Although symptoms are different from bug #586406 fix is same. You can test fixed package from https://bugzilla.redhat.com/show_bug.cgi?id=586406#c3, update will be available soon.
Comment 8 Adam Tkac 2010-05-13 06:49:19 EDT

*** This bug has been marked as a duplicate of bug 586406 ***

Note You need to log in before you can comment on or make changes to this bug.