Bug 58033 - X on i815 "falls" at switching from a X > console
X on i815 "falls" at switching from a X > console
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-06 12:07 EST by Maxim V. Kryzhny
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 15:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xconfile (1020 bytes, application/octet-stream)
2002-01-06 12:38 EST, Maxim V. Kryzhny
no flags Details
Xlogfile (5.72 KB, application/octet-stream)
2002-01-06 12:47 EST, Maxim V. Kryzhny
no flags Details

  None (edit)
Description Maxim V. Kryzhny 2002-01-06 12:07:34 EST
Description of Problem:
At switching from a graphic mode in a console, X-system "falls" with 

probability near 40-50%. 
Such crashes is not observed at set-up of X-system with an option - 
preferxf3 of the program Xconfigurator. 
But such mode of operation essentially reduces 
functionality of all X-system. 
my videodevice - Intel (R) 82815 Graphics Controller;

Version-
Release number of selected component (if applicable):
XFree86 Version 4.1.0 (Red Hat Linux 
release: 4.1.0-3) / X Window System
(protocol Version 11, revision 0, vendor release 
6510)
Release Date: 2 June 2001;

How Reproducible:
sometimes, probability near 40-50%; 


Steps to Reproduce:
1. run X or startx > x.out 2>&1
2. press Ctrl-Alt-[F1-F6]
3. Oops;

Actual 
Results:
X crushed & i loses data of all X' apps;

Expected Results:
X not crushed &...;

Additional 
Information:
Te last messages from the file XFree86.0.log:  
--- 
pgetbl_ctl: 0xca10001 
pgetbl_err: 0x0 
ipeir: 0 iphdr: 0 
LP ring tail: 8 head: 0 len: 0 start 0 
eir: 0 esr: 0 emr: 3d 
instdone: 
ff7b instpm: 0 
memmode: 4 instps: 0 
hwstam: 0 ier: 3 imr: 0 iir: 0 
space: 65520 wanted 65528 

(II) I810 (0): [drm] removed 1 reserved context for kernel 
(II) I810 (0): [drm] unmapping 4096 
bytes of SAREA 0xd094f000 at 0x40018000 
 
Fatal server error: 
lockup 
--- .
Comment 1 Maxim V. Kryzhny 2002-01-06 12:38:36 EST
Created attachment 41893 [details]
Xconfile
Comment 2 Maxim V. Kryzhny 2002-01-06 12:47:42 EST
Created attachment 41894 [details]
Xlogfile
Comment 3 Mike A. Harris 2002-01-24 21:05:49 EST
In the future.. please don't compress file attachments before
attaching them.  We've got lots of disk space.  ;o)

Ok.. I downloaded, uncompressed, and viewed your logfile...  ;o)

It appears that there is something going wrong with DRI.  Are you
sure you've got AGP properly configured in your CMOS?

Also, please upgrade to our latest erratum kernel and XFree86
release.  Many bugs have been fixed, including bugs directly
related to i8x0 adaptors.

Thanks.
Comment 4 Maxim V. Kryzhny 2002-01-25 16:20:36 EST
hi!
> please don't compress file attachments before
> attaching them.  We've got lots of disk space.  ;o)
Excuse me, I did not know all rules.
> Ok.. I downloaded, uncompressed, and viewed your logfile...  ;o)
Excuse me once again :)
> It appears that there is something going wrong with DRI.
> Are you sure you've got AGP properly configured in your CMOS?
Who in it can be sure except for the "!!!"? :)
For me the standard options from the supplier 
(aka "Optimized Defaults") are installed.
There is still mode
"Fail-Safe Defaults". But on my observations they do not improve
stability. Besides it is possible to change options of the
videosystem not completely, and separately. I attend by it.
If suddenly there will occur improvement of PChealth, I
necessarily shall inform about this event the World.
> Also, please upgrade to our latest erratum kernel and XFree86
> release. 
okok&Thanks.
Comment 5 Need Real Name 2002-03-25 12:23:14 EST
I also have the same problem that when I switch to a virtual terminal, X dies 
and restarts - and all x-based apps also die (in Gnome or KDE). I have applied 
ALL applicable updates to my system. I did not notice the error occuring until 
after I had performed some of the updates... However, because of the less than 
100% probability of the crash, I do not know when the problem started.

It is not dependant on up time.

I have an Intel 810 AGP (i810).
Comment 6 Mike A. Harris 2002-05-21 05:23:56 EDT
I strongly suggest if you're still having this problem, that you upgrade to
Red Hat Linux 7.3, make sure your computer's BIOS is flashed to the
manufacturer's latest BIOS images, and that you have AGP configured
properly in the CMOS settings.  Many users use i810/i815 video hardware in
Linux, and I'm not receiving many bug reports at all.  Any reports similar
to this one that I've received have all turned out to be configuration issues,
either of X itself, or of the computer's CMOS settings, etc.

I also recommend discussing the problem on xpert@xfree86.org mailing list
and reporting back here the results of your inquiry.
Comment 7 Mike A. Harris 2002-09-05 09:07:03 EDT
This issue was fixed a while back in rawhide.  Closing bug as RAWHIDE.
Comment 8 Maxim V. Kryzhny 2002-09-06 15:08:48 EDT
> This issue was fixed a while back in rawhide.
> Closing bug as RAWHIDE.

 Thank, but I (and not 
only)have not understood that means "Closing bug as
 RAWHIDE". What it means?
 And from yours 
message to kry@mg.dp.ua:

> I also recommend discussing the problem on 
xpert@xfree86.org
> mailing list and reporting back here the results of your inquiry.

ok, 
but this problem in Aug, 01 I (and not only) already have described in this mailist. To my regret, 
the experts in the given question have not reacted. If it will help, the references:

 
http://www.xfree86.org/pipermail/xpert/2001-February/005641.html
 
http://www.xfree86.org/pipermail/xpert/2001-June/009246.html
 
http://www.xfree86.org/pipermail/xpert/2001-June/009249.html 
 
http://www.xfree86.org/pipermail/xpert/2001-June/009254.html 
 
http://www.xfree86.org/pipermail/xpert/2001-June/009279.html 
 
http://www.xfree86.org/pipermail/xpert/2001-July/010050.html 
 
http://www.xfree86.org/pipermail/xpert/2001-July/010054.html 
 
http://www.xfree86.org/pipermail/xpert/2001-July/010072.html 
 
http://www.xfree86.org/pipermail/xpert/2001-August/010636.html ***
 
http://www.xfree86.org/pipermail/xpert/2001-September/011222.html 

What means 
"CLOSED RAWHIDE"?
Probably there is any reference (HTML) on this "fixed"?
As far as I know, 
till now problem is not fixed!!

thnx
Comment 9 Mike A. Harris 2002-09-07 04:20:57 EDT
Bugzilla is not a tech support forum, sorry.  If you need tech support
to resolve the fixed issue, please consult with one of our tech
support representatives at 1-888-RED-HAT1 or use one of our mailing
lists.

Rawhide is Red Hat developmental packages.  Reopening the bug that
is resolved as fixed, does not get you tech support or help, please
do not reopen the bug report unless you upgrade to rawhide and the
problem persists.

Note You need to log in before you can comment on or make changes to this bug.