Bug 580432 - [Workaround] Cannot launch jvisualvm after Netbeans update
Summary: [Workaround] Cannot launch jvisualvm after Netbeans update
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 13
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Martin Matejovic
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-08 09:15 UTC by Mat Booth
Modified: 2010-06-10 19:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 11:37:44 UTC


Attachments (Terms of Use)

Description Mat Booth 2010-04-08 09:15:48 UTC
After upgrading to F13, JVisualVM no longer launches from the link in the applications menu. (The menu item Applications->Programming->VisualVM.)

When launched from the terminal, I see this:

[mbooth@su6951 ~]$ jvisualvm 
/bin/bash: /usr/lib/jvm/java-1.6.0-openjdk/bin/../lib/visualvm//platform*/lib/nbexec: No such file or directory

I have this version installed:

java-1.6.0-openjdk-devel.i686   1:1.6.0.0-36.b17.fc12

Also it might be worth noting that /etc/alternatives/jvisualvm and /usr/bin/jvisualvm are not owned by any package on my system.

Comment 1 Mat Booth 2010-04-08 09:41:20 UTC
It is caused by Netbeans being upgraded to platform11, because VisualVM has a broken symlink to platform10 in its directory.

Doing the following fixed it for me:

cd /usr/lib/jvm/java-1.6.0-openjdk/lib/visualvm
su -c 'rm -rf platform10'
su -c 'ln -s /usr/share/netbeans/platform11/ .'

Comment 2 Fedora Update System 2010-05-13 07:53:19 UTC
java-1.6.0-openjdk-1.6.0.0-38.b18.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-38.b18.fc13

Comment 3 Fedora Update System 2010-06-10 12:47:07 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-39.b18.fc13

Comment 4 Fedora Update System 2010-06-10 19:19:00 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.