Bug 58049 - rpm does not work when LANG=tr_TR
Summary: rpm does not work when LANG=tr_TR
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 23199 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-07 11:36 UTC by Gorkem Cetin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 17:05:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gorkem Cetin 2002-01-07 11:36:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
rpm does not work propoerly (particularly while installing a package)
when the environment var LANG is equal to tr_TR. It simply gives 
a lot of dependencies and exit, however those dependencies are already solved
before.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.export LANG=tr_TR
2.rpm -i any_package_having_no_dep_problem.rpm
3.(it doesn't install, exits with a lot of dependency errors)
 

Actual Results:  RPM installation breaks

Expected Results:  RPM installation should have been successfull :-)
I've submmitted this bug when 7.1 was out, but there was
no fix in 7.2. Still, Turkish users cannot use RPM properly :-(

Additional info:

# export LANG=tr_TR
# rpm -i mrproject-0.3.2-1.i386.rpm
dbiTagsInit: tan}mlanmam}~ etiket ad}: "Requirename" yoksay}ld}
dbiTagsInit: tan}mlanmam}~ etiket ad}: "Providename" yoksay}ld}
dbiTagsInit: tan}mlanmam}~ etiket ad}: "Conflictname" yoksay}ld}
dbiTagsInit: tan}mlanmam}~ etiket ad}: "Triggername" yoksay}ld}
hata: bap}ml}l}klarda hata; gerekli paketler:
        ld-linux.so.2   mrproject-0.3.2-1 igin gerekli
        libart_lgpl.so.2   mrproject-0.3.2-1 igin gerekli
        libaudiofile.so.0   mrproject-0.3.2-1 igin gerekli
        libbonobo.so.2   mrproject-0.3.2-1 igin gerekli
        libbonobox.so.2   mrproject-0.3.2-1 igin gerekli
        libORBitCosNaming.so.0   mrproject-0.3.2-1 igin gerekli
        libORBit.so.0   mrproject-0.3.2-1 igin gerekli
        libORBitutil.so.0   mrproject-0.3.2-1 igin gerekli
        libpng.so.2   mrproject-0.3.2-1 igin gerekli
        libpopt.so.0   mrproject-0.3.2-1 igin gerekli
        libpthread.so.0   mrproject-0.3.2-1 igin gerekli
        libSM.so.6   mrproject-0.3.2-1 igin gerekli
        libtiff.so.3   mrproject-0.3.2-1 igin gerekli
        libunicode.so.0   mrproject-0.3.2-1 igin gerekli
        libX11.so.6   mrproject-0.3.2-1 igin gerekli
        libXext.so.6   mrproject-0.3.2-1 igin gerekli
        libXi.so.6   mrproject-0.3.2-1 igin gerekli
        libxml.so.1   mrproject-0.3.2-1 igin gerekli
        libz.so.1   mrproject-0.3.2-1 igin gerekli
        libc.so.6(GLIBC_2.0)   mrproject-0.3.2-1 igin gerekli
        libc.so.6(GLIBC_2.1)   mrproject-0.3.2-1 igin gerekli
        libc.so.6(GLIBC_2.1.3)   mrproject-0.3.2-1 igin gerekli
        libpthread.so.0(GLIBC_2.0)   mrproject-0.3.2-1 igin gerekli

Comment 1 Jeff Johnson 2002-01-07 21:30:19 UTC
*** Bug 23199 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2002-03-19 19:52:40 UTC
I'd love to "fix" this problem, but don't know
how to reproduce with rpm-4.0.4.

Can you try rpm-4.0.4? AFAIK, I use ASCII
only internal functions for configuration
for db parsing, but there's apparently someplace
still broken ...

Comment 3 Gorkem Cetin 2002-03-20 17:05:12 UTC
I see (quite happily) that no problem occurs with 4.0.4 - using 7.2.91..

export LANG=tr_TR 
rpm -i something.rpm 
(installs flawlessly)


Note You need to log in before you can comment on or make changes to this bug.