Bug 58062 - All NICs respond to ARP requests for any NIC in the system
All NICs respond to ARP requests for any NIC in the system
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-07 10:52 EST by Matt Domsch
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 09:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eth0-sniff (594 bytes, text/plain)
2002-01-07 10:53 EST, Matt Domsch
no flags Details
eth1-sniff (746 bytes, text/plain)
2002-01-07 10:53 EST, Matt Domsch
no flags Details
switch console log (20.77 KB, text/plain)
2002-01-07 10:54 EST, Matt Domsch
no flags Details

  None (edit)
Description Matt Domsch 2002-01-07 10:52:38 EST
Description of Problem:
 Both of the LOMs (LAN-on-Motherboard, or onboard NICs) are responding to ARP 
requests for each of the LOMs on the (forthcoming Dell) system.

If an ARP request is made to either of the LOMs for an IP address either of the 
LOMs has it responds as the owner.

This leads to corruption of the ARP tables on switches wherein VLANning is 
employed and the server spans both VLANs.

Attached are the logs from the switch, and from TCP/IP sniffing

UPDATE - Thomas Chenault 1/02/02
I have tested for this condition using other servers and NICs (Intel and 
Broadcom) and found the behavior to be the same. Both Red Hat 7.1 and 7.2 
behave as described above, responding to ARP requests on all receiving 
interfaces. 

I am aware of two circumstances under which the behavior can be observed:
   1) when pinging from a switch to a server which exposes multiple physical
       interfaces to the switch (as described in this issue).
   2) when multiple physical interfaces are exposed to a single physical subnet
       which is divided into multiple logical subnets.

I will begin discussions with our Linux team. I recommend that:
   1) the issue be moved from the Dagger bucket to the Linux bucket.
   2) the issue be lowered to sev. 3 due to limited impact.

UPDATE - Thomas Chenault 1/07/02
I have confirmed that the behavior is the same when with Red Hat 7.0 (2.2 
kernel). 

Version-Release number of selected component (if applicable):
Red Hat Linux 7.0, 7.1 SBE, 7.2.


How Reproducible:
Always

Steps to Reproduce:
1. See above
2. 
3. 

Actual Results:
ARP requests for other NICs on multihomed system are responded to.

Expected Results:
No ARP responses for the other NICs should be sent.

Additional Information:
Comment 1 Matt Domsch 2002-01-07 10:53:16 EST
Created attachment 41931 [details]
eth0-sniff
Comment 2 Matt Domsch 2002-01-07 10:53:58 EST
Created attachment 41932 [details]
eth1-sniff
Comment 3 Matt Domsch 2002-01-07 10:54:34 EST
Created attachment 41933 [details]
switch console log
Comment 4 Arjan van de Ven 2002-01-07 11:01:17 EST
VLAN will most likely be supported as of the next RHL release; linux supports
vlans as of kernel 2.4.16.

If the switch gets upset then it's a problem already; I'm talking to our TCP/IP
guys about it.
Comment 5 Arjan van de Ven 2002-01-08 09:09:37 EST
This appears "as designed"; this failover behavior can be turned off with
arpfilter:
/proc/sys/net/ipv4/conf/*/arp_filter

Note You need to log in before you can comment on or make changes to this bug.