Bug 58067 - Non-root user can umount partition when this is not permitted by fstab
Non-root user can umount partition when this is not permitted by fstab
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
: 56593 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-07 13:36 EST by Richard D. McRoberts
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 09:38:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Showing ordinary unmounting a partition not allowed in fstab (1.26 KB, text/plain)
2002-01-07 13:38 EST, Richard D. McRoberts
no flags Details

  None (edit)
Description Richard D. McRoberts 2002-01-07 13:36:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
In /etc/fstab the partition has the "owner" option but NOT user.
The ordinary user does NOT own the device file as the manpage mount(8)
specifies as being required for "owner" to work.  Only root can mount
the partition, but an ordinary user can umount it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Detailed in attachment
2 [details].
3.
	

Actual Results:  See attachment

Expected Results:  The ordinary user "peon" should not have been able to unmount the
partition.

Additional info:
Comment 1 Richard D. McRoberts 2002-01-07 13:38:00 EST
Created attachment 41952 [details]
Showing ordinary unmounting a partition not allowed in fstab
Comment 2 Bernhard Rosenkraenzer 2002-01-17 09:38:32 EST
Verified. Assigning to util-linux where mount lives these days.
Comment 3 Elliot Lee 2002-01-29 15:22:50 EST
util-linux-2.11n-3 has a patch to fix this, and the upstream maintainer has
fixed it in his tree.
Comment 4 Elliot Lee 2002-01-29 16:36:48 EST
*** Bug 56593 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.