Bug 580812 - Inserting disk in dvd drive removes symbolic device links
Inserting disk in dvd drive removes symbolic device links
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 02:03 EDT by Danny Ciarniello
Modified: 2010-04-23 18:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: udev-145-20.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 18:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Ciarniello 2010-04-09 02:03:40 EDT
Description of problem: 
When there is no disk in my dvd drive, there are four symbolic links in /dev pointing to the actual device file, /dev/cdrom, /dev/cdrw, /dev/dvd and /dev/dvdrw.  When a disk (CD or DVD) is inserted, the symbolic links disappear.  When the disk is ejected, the symbolic links reappear.

This causes problems with programs that rely on the presence of these devices.

E. g. mencoder dvd://1 ...
does not work because it can't find /dev/dvd

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. insert a disk in dvd drive
2. 
3. 
  
Actual results:
/dev/cdrom, /dev/cdrw, /dev/dvd and /dev/dvdrw disappear


Expected results:
/dev/cdrom, /dev/cdrw, /dev/dvd and /dev/dvdrw don't disappear

Additional info: 
Note that I am doing this under KDE 4.4
Also, I don't know that DeviceKit is the issue but that's my best guess as to the proper component
Comment 1 Danny Ciarniello 2010-04-09 02:11:21 EDT
This does have anything to do with KDE since it also happens in runlevel 3 (i. e. no X)
Comment 2 Fedora Update System 2010-04-13 12:41:09 EDT
udev-145-20.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/udev-145-20.fc12
Comment 3 Fedora Update System 2010-04-14 23:16:21 EDT
udev-145-20.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/udev-145-20.fc12
Comment 4 Fedora Update System 2010-04-23 18:58:15 EDT
udev-145-20.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.