Bug 58112 - <rpcsvc/rquota.h> missing
Summary: <rpcsvc/rquota.h> missing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: quota   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-08 23:00 UTC by Daniel Resare
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 23:00:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Resare 2002-01-08 23:00:39 UTC
Description of Problem:

Compilation of programs including <rpcsvc/rquota.h> fails since the file
/usr/include/rpcsvc/rquota.h it is not present on a redhat-7.1 system when glibc
and quota errata is applied

Version-Release number of selected component (if applicable):

the file in question disappeared in the upgrade from glibc-devel-2.2.2-10 to
glibc-devel-2.2.4-19.3. In redhat-7.2 the file in question is moved to the quota
package, but the file is not present in quota-3.01pre9-0.7.1 which is latest
errata for 7.1.

Comment 1 Phil Copeland 2002-08-07 19:29:34 UTC
From the make install section of quota:
        -$(INSTALL) -m 755 -d $(ROOTDIR)$(includedir)/rpcsvc
        -$(INSTALL) -m 644 rquota.h rquota.x $(ROOTDIR)$(includedir)/rpcsvc

Quota installs this file in /usr/include/rpcsvc

There is an errata in the pipline using the base quota package from
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/quota-3.06*
That should address this problem once the errata gets through QA

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.