Bug 58123 - C-Media 8738 cmpci.o driver does not support modem
C-Media 8738 cmpci.o driver does not support modem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 05:18 EST by Sharuzzaman Ahmat Raslan
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharuzzaman Ahmat Raslan 2002-01-09 05:18:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
C-Media 8738 cmpci.o stock driver does not support built-in PCTel modem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rmmod cmpci
2. modprobe cmpci
3. tail /var/log/messages
4. kernel log will say that the driver is cmpci vX.X -nomodem
	

Actual Results:  If I install PCTel modem driver, the modem will simply not 
work because the link between the sound chip and the modem is not enabled.

Expected Results:  If the cmpci.o support the PCTel modem, the modem can be 
used without the need to recompiling the driver.

Additional info:

The download page of the driver that support PCTel modem is at
http://www.cmedia.com.tw/download/e-cmi8738_linux.htm

The file that contain the source code for the driver that support PCTel modem is
http://www.cmedia.com.tw/8x38/linux/cmpci-4.03.tar.gz

It is coded by the hardware developer themselves.

I file this as bug because I hate to recompile the driver again and again since 
RedHat 6.2, RedHat 7.0 and now RedHat 7.1. I think that RedHat 7.2 will also 
not support the PCTel modem. (cannot confirm because not tested it). I need to 
use my PCTel Win/LinModem and I don't want to do the same task, again and again.
Comment 1 Alan Cox 2003-06-07 20:13:38 EDT
The modem driver is binary only not open source so not something Red Hat will fix

Note You need to log in before you can comment on or make changes to this bug.