Bug 581260 - color of icon to mark selected packages is not distinct enough
color of icon to mark selected packages is not distinct enough
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-11 09:00 EDT by Oded Arbel
Modified: 2010-04-11 11:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-11 11:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2010-04-11 09:00:43 EDT
Description of problem:
In the KPackageKit software installation UI - used in the KDE desktop - packages to be installed are marked with a blue arrow while packages that are not going to be installed are marked with a gray arrow. 

The problem is that the "blue" color of the arrow is very grayish looking - the actual color code is #9FC0F2 which has high value red and green components, and with some screens that do not have very strong contrast (most low-cost LCDs) it is hard to distinguish between the colors, especially under poor lighting conditions (standard fluorescent office lights).

Version-Release number of selected component (if applicable):
0.6.0-2
although the problem is probably due to using the go-down action icon from oxygen-icon-theme-4.4.2-1.fc13

How reproducible:
Always
Comment 1 Kevin Kofler 2010-04-11 11:53:06 EDT
Well, I'm not convinced this is a bug in the first place. If you think this is that bad a usability issue, please bring it to upstream's attention. But KPackageKit intentionally uses system icons (which are Oxygen by default), that's not likely to (and IMHO should not) change. You MIGHT be able to get the Oxygen designers to change the icon's color, but I doubt it, as Oxygen has a well-defined palette for consistency across all icons. All in all, the choice of color is the result of a global system consistency decision (using system icons for consistency with other apps, and those icons use Oxygen palette colors for consistency with other icons), sometimes global consistency requires some tradeoff in individual apps.

Note You need to log in before you can comment on or make changes to this bug.