Bug 58155 - compile crashed (c-client for imap from ftp.cac.washington.edu)
Summary: compile crashed (c-client for imap from ftp.cac.washington.edu)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 11:57 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:05:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-01-10 11:57:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
this was a compile of the imap-2001a.tar.gz off ftp.cac.washington.edu

cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
`cat CCTYPE` -c `cat CFLAGS` mail.c
`cat CCTYPE` -c `cat CFLAGS` misc.c
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
`cat CCTYPE` -c `cat CFLAGS` smanager.c
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
`cat CCTYPE` -c `cat CFLAGS` utf8.c
`cat CCTYPE` -c `cat CFLAGS` siglocal.c
`cat CCTYPE` -c `cat CFLAGS` dummy.c
`cat CCTYPE` -c `cat CFLAGS` pseudo.c
`cat CCTYPE` -c `cat CFLAGS` netmsg.c
`cat CCTYPE` -c `cat CFLAGS` flstring.c
`cat CCTYPE` -c `cat CFLAGS` fdstring.c
`cat CCTYPE` -c `cat CFLAGS` rfc822.c
`cat CCTYPE` -c `cat CFLAGS` nntp.c
`cat CCTYPE` -c `cat CFLAGS` smtp.c
`cat CCTYPE` -c `cat CFLAGS` imap4r1.c
`cat CCTYPE` -c `cat CFLAGS` pop3.c
`cat CCTYPE` -c `cat CFLAGS` unix.c
`cat CCTYPE` -c `cat CFLAGS` mbox.c
`cat CCTYPE` -c `cat CFLAGS` mbx.c
mbx.c: In function `mbx_parse':
mbx.c:1192: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [mbx.o] Error 1
make[3]: Leaving directory `/installs/imap-2001a/c-client'
make[2]: *** [slx] Error 2
make[2]: Leaving directory `/installs/imap-2001a/c-client'
make[1]: *** [OSTYPE] Error 2
make[1]: Leaving directory `/installs/imap-2001a'
make: *** [slx] Error 2
[root@dev1_attune imap-2001a]# 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download imap-2001a.tar.Z from ftp.cac.washington.edu/imap
2.untar
3.make slx
	

Actual Results:  The compile reported errors.

Expected Results:  Should have compiled

Additional info:

cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
`cat CCTYPE` -c `cat CFLAGS` mail.c
`cat CCTYPE` -c `cat CFLAGS` misc.c
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
`cat CCTYPE` -c `cat CFLAGS` smanager.c
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
`cat CCTYPE` -c `cat CFLAGS` utf8.c
`cat CCTYPE` -c `cat CFLAGS` siglocal.c
`cat CCTYPE` -c `cat CFLAGS` dummy.c
`cat CCTYPE` -c `cat CFLAGS` pseudo.c
`cat CCTYPE` -c `cat CFLAGS` netmsg.c
`cat CCTYPE` -c `cat CFLAGS` flstring.c
`cat CCTYPE` -c `cat CFLAGS` fdstring.c
`cat CCTYPE` -c `cat CFLAGS` rfc822.c
`cat CCTYPE` -c `cat CFLAGS` nntp.c
`cat CCTYPE` -c `cat CFLAGS` smtp.c
`cat CCTYPE` -c `cat CFLAGS` imap4r1.c
`cat CCTYPE` -c `cat CFLAGS` pop3.c
`cat CCTYPE` -c `cat CFLAGS` unix.c
`cat CCTYPE` -c `cat CFLAGS` mbox.c
`cat CCTYPE` -c `cat CFLAGS` mbx.c
mbx.c: In function `mbx_parse':
mbx.c:1192: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [mbx.o] Error 1
make[3]: Leaving directory `/installs/imap-2001a/c-client'
make[2]: *** [slx] Error 2
make[2]: Leaving directory `/installs/imap-2001a/c-client'
make[1]: *** [OSTYPE] Error 2
make[1]: Leaving directory `/installs/imap-2001a'
make: *** [slx] Error 2
[root@dev1_attune imap-2001a]#

Comment 1 Mike A. Harris 2002-01-18 07:51:47 UTC
This is not a bug in Red Hat Linux imap package.  Bugzilla is for bugs
in the packages that ship with Red Hat Linux.  It looks like a compiler
bug perhaps, although it could be something else also.  I am reassigning
it to gcc component for Jakub to look at.



Comment 2 Jakub Jelinek 2002-01-28 11:46:04 UTC
When you retry, do you get the same error while compiling the same file?
If yes, please post here what options were passed to gcc (
echo `cat CCTYPE` -c `cat CFLAGS` mbx.c
might do the job), rerun it with -save-temps and attach here mbx.i.

Comment 3 Alan Cox 2002-12-15 19:05:50 UTC
Assuming retry didnt crash as no reply



Note You need to log in before you can comment on or make changes to this bug.