Bug 58185 - Please add ADA-frontend
Summary: Please add ADA-frontend
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 18:55 UTC by Enrico Scholz
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-09 19:08:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-01-10 18:55:52 UTC
Since -- in opposite to bug #57172 -- the gnat frontend builds fine in recent
gcc versions, I would like to see -ada subpackages providing it...

I have tested it with gcc-3.1-0.{14,17} and bootstrapped with gnat-3.13p-4 from
powertools.

Comment 1 Jakub Jelinek 2002-01-15 14:29:18 UTC
Well, I tried to do this for gcc-3.1-0.18, but it did not work
(installed gnat-3.31p-4, when building it died on some stage1/gnatbind error).
I'll retry next time I update rpm to CVS to see if this is not just a
transient problem (I don't know Ada at all, so I'd prefer not to debug bugs
in it).

Comment 2 Enrico Scholz 2002-01-17 20:56:50 UTC
Strange; just rebuilt gcc-3.1-0.18 (+ada frontend) in the following environment:

| glibc-2.2.90-3 (i686 architecture)
| binutils-2.11.92.0.12-8
| gcc-3.1-0.17
| gnat-3.13p-4
| gnat-devel-3.13p-4

Was the gnat-devel package installed at your try?

Comment 3 LENHOF 2002-02-09 19:08:45 UTC
It will be very to add this Ada frontend...

Ada is a so good language...

Comment 4 Jakub Jelinek 2002-08-12 13:49:58 UTC
gcc-gnat has been added long time ago, forgot to close this.


Note You need to log in before you can comment on or make changes to this bug.