Bug 58198 - Install fails if user has to shrink number of packages installed
Summary: Install fails if user has to shrink number of packages installed
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 22:39 UTC by Bill Peck
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Peck 2002-01-10 22:39:16 UTC
Description of Problem:

Choose too many packages to install and anaconda catches this during the
"preparing to install" phase.  If you go back to correct the problem by choosing
fewer files then when the install is done the reboot will fail because no disks
will be mounted I believe.
fstab will end up with entries like:
LABEL=/1                 /                       ext3    defaults        1 1
LABEL=/boot1             /boot                   ext3    defaults        1 2
It seems to me that some procedure is being repeated and it shouldn't

Version-Release number of selected component (if applicable):


How Reproducible:
Everytime

Steps to Reproduce:
1. choose a larger package base than what will fit on your drive
2. after it complains that it won't fit go back and reduce the number of packages
3. install will finish (making boot floppy will fail, says it kind find root
drive in fstab) and after reboot system will not come up.
	

Actual Results:
devices get appended a 1 after there names. 

Expected Results:

To recognise the difference between disks that existed before the install and
disks that were created during the install.  These disks shouldn't have a 1
appended to them

Additional Information:

Comment 1 Michael Fulbright 2002-03-26 17:30:25 UTC
Deferring to future release.

Comment 2 Red Hat Bugzilla 2006-02-21 18:48:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.