Bug 58199 - uncorrect image translation with latex2html
Summary: uncorrect image translation with latex2html
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 22:41 UTC by Rodary Jacques
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 18:32:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rodary Jacques 2002-01-10 22:41:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Math formulas come with a left and bottom black border when translated in png
image. I could'nt correct this with latex2html (or l2hconf.pm) or pnmtopng
options. It could be a netpbm issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile a latex document with math formulas (between $ signs)with latex2html
2.view the result with any browser
3.
	

Actual Results:  There was'nt any problem with
latex2html-98_2beta6-1.noarch.rpm, libgr-2.0.13-23.i386.rpm,
libgr-progs-2.0.13-23.i386.rpm, and old (0.96) tetex-* releases.

Additional info:

Comment 1 Tim Waugh 2002-01-11 11:58:25 UTC
Thanks for reporting this.  The fix turns out to be just to new a newer 
tarball of latex2html.


Comment 2 Rodary Jacques 2002-01-11 18:49:59 UTC
The bug seems to depend on netpbm/netpbm-progs: I forced installation of
libgr-2.0.13-23.i386.rpm, libgr-progs-2.0.13-23.i386.rpm, and
latex2html-98_2beta6-1.noarch.rpm, and everything is OK with gif images, even
with latest versions of tetex/tetex-latex, of course after removing
/usr/bin/latex2html and /usr/bin/pstoimg.

Comment 3 Tim Waugh 2002-01-11 19:03:02 UTC
Er.. we ship latex2html as part of tetex-latex.

Really, the problem is just that the latex2html version was too old.  2K.1beta 
(1.61) works fine here.


Comment 4 Rodary Jacques 2002-01-12 15:02:25 UTC
No way: I first had the problem with latex2html  version 2K.1beta (1.79) from
tetex-latex-1.0.7-38.2

Comment 5 Rodary Jacques 2002-01-12 15:06:20 UTC
No way: I first had the problem with latex2html  version 2K.1beta (1.79) from
tetex-latex-1.0.7-38.2.

Comment 6 Tim Waugh 2002-01-12 16:19:23 UTC
1.0.7-38.2 has 2K.1beta (1.47).


Comment 7 Rodary Jacques 2002-01-13 01:24:11 UTC
Sorry, I looked at the wrong place! Where can I find version 2K.1beta 
(1.61)?



Comment 9 Tim Waugh 2002-01-17 14:49:18 UTC
Updated package is tetex 1.0.7-39.


Comment 10 Rodary Jacques 2002-01-21 18:29:32 UTC
I still have the same problem with png images, not with gif, and with math
symbols like \in,\subset and so on. I do believe the issue is with netpbm or
netpbm-progs, from redhat 7.0, 7.1, and 7.2.

Comment 11 Rodary Jacques 2002-01-21 18:30:28 UTC
I still have the same problem with png images, not with gif, and with math
symbols like \in,\subset and so on. I do believe the issue is with netpbm or
netpbm-progs, from redhat 7.0, 7.1, and 7.2.

Comment 12 Tim Waugh 2002-01-21 18:31:51 UTC
Please attach a test case.


Comment 13 Tim Waugh 2002-02-01 14:42:21 UTC
Closing.  If you are still having the problem, please re-open and attach a test case.



Note You need to log in before you can comment on or make changes to this bug.