Bug 58199 - uncorrect image translation with latex2html
uncorrect image translation with latex2html
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 17:41 EST by Rodary Jacques
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 13:32:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodary Jacques 2002-01-10 17:41:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Math formulas come with a left and bottom black border when translated in png
image. I could'nt correct this with latex2html (or l2hconf.pm) or pnmtopng
options. It could be a netpbm issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile a latex document with math formulas (between $ signs)with latex2html
2.view the result with any browser
3.
	

Actual Results:  There was'nt any problem with
latex2html-98_2beta6-1.noarch.rpm, libgr-2.0.13-23.i386.rpm,
libgr-progs-2.0.13-23.i386.rpm, and old (0.96) tetex-* releases.

Additional info:
Comment 1 Tim Waugh 2002-01-11 06:58:25 EST
Thanks for reporting this.  The fix turns out to be just to new a newer 
tarball of latex2html.
Comment 2 Rodary Jacques 2002-01-11 13:49:59 EST
The bug seems to depend on netpbm/netpbm-progs: I forced installation of
libgr-2.0.13-23.i386.rpm, libgr-progs-2.0.13-23.i386.rpm, and
latex2html-98_2beta6-1.noarch.rpm, and everything is OK with gif images, even
with latest versions of tetex/tetex-latex, of course after removing
/usr/bin/latex2html and /usr/bin/pstoimg.
Comment 3 Tim Waugh 2002-01-11 14:03:02 EST
Er.. we ship latex2html as part of tetex-latex.

Really, the problem is just that the latex2html version was too old.  2K.1beta 
(1.61) works fine here.
Comment 4 Rodary Jacques 2002-01-12 10:02:25 EST
No way: I first had the problem with latex2html  version 2K.1beta (1.79) from
tetex-latex-1.0.7-38.2
Comment 5 Rodary Jacques 2002-01-12 10:06:20 EST
No way: I first had the problem with latex2html  version 2K.1beta (1.79) from
tetex-latex-1.0.7-38.2.
Comment 6 Tim Waugh 2002-01-12 11:19:23 EST
1.0.7-38.2 has 2K.1beta (1.47).
Comment 7 Rodary Jacques 2002-01-12 20:24:11 EST
Sorry, I looked at the wrong place! Where can I find version 2K.1beta 
(1.61)?

Comment 9 Tim Waugh 2002-01-17 09:49:18 EST
Updated package is tetex 1.0.7-39.
Comment 10 Rodary Jacques 2002-01-21 13:29:32 EST
I still have the same problem with png images, not with gif, and with math
symbols like \in,\subset and so on. I do believe the issue is with netpbm or
netpbm-progs, from redhat 7.0, 7.1, and 7.2.
Comment 11 Rodary Jacques 2002-01-21 13:30:28 EST
I still have the same problem with png images, not with gif, and with math
symbols like \in,\subset and so on. I do believe the issue is with netpbm or
netpbm-progs, from redhat 7.0, 7.1, and 7.2.
Comment 12 Tim Waugh 2002-01-21 13:31:51 EST
Please attach a test case.
Comment 13 Tim Waugh 2002-02-01 09:42:21 EST
Closing.  If you are still having the problem, please re-open and attach a test case.

Note You need to log in before you can comment on or make changes to this bug.