Bug 58200 - Fails to build
Summary: Fails to build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnucash (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 23:14 UTC by Enrico Scholz
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 23:45:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-01-10 23:14:47 UTC
Description of Problem:

Rebuilding of gnucash fails because of missing files (probably patched away):

| rpm --rebuild gnucash-1.6.5-1.src.rpm
| config.status: creating src/optional/swig/Makefile
| config.status: error: cannot find input file: src/optional/swig/Makefile.in
| error: Bad exit status from /var/tmp/rpm-tmp.93611 (%build)
|     Bad exit status from /var/tmp/rpm-tmp.93611 (%build)

Removing all the swig/* Makefile-entries from configure.in cures the problem.


Version-Release number of selected/related components (if applicable):

gnucash-1.6.5-1.src.rpm
automake-1.5-2
autoconf-2.52-5

Comment 1 Enrico Scholz 2002-02-25 21:53:26 UTC
Still in gnucash-1.6.5-3.src.rpm

Comment 2 Bill Nottingham 2002-02-25 22:17:06 UTC
There were files missing in the upstream tarball.

Comment 3 Bill Nottingham 2002-02-25 22:18:26 UTC
... that cause breakages with newer automake/autoconf.

Comment 4 Enrico Scholz 2002-02-25 23:45:40 UTC
I do not see where the problem lies. 'autoconf' will be called in the current
package in %build and works with autoconf-2.52-7 and automake-1.5-8. Therefore,
removing the two 

|         src/optional/swig/Makefile
|         src/optional/swig/examples/Makefile

lines from AC_OUTPUT in configure.in will not break anything.


-----

A quick & dirty hack without patching would be

| p=src/optional/swig
| mkdir -p $p/examples
| touch $p/Makefile.in $p/examples/Makefile.in

in the %setup or early %build section of the .spec-file.

Comment 5 Bill Nottingham 2002-12-04 03:13:46 UTC
Should be fixed with current packages, certainly with 1.7.5-1.


Note You need to log in before you can comment on or make changes to this bug.