Bug 58203 - gated static default route not listed in routing tables
gated static default route not listed in routing tables
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: gated (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 19:12 EST by abgrubbs
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gated dump file (23.46 KB, text/plain)
2002-01-10 19:14 EST, abgrubbs
no flags Details
gated log (10.80 KB, text/plain)
2002-01-10 19:16 EST, abgrubbs
no flags Details

  None (edit)
Description abgrubbs 2002-01-10 19:12:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.06 [en] (WinNT; U ;Nav)

Description of problem:
I'm using a RH 7.0 system that has been updated to 2.2.19-7.0.12 kernel.

I have installed the gated-3.6-12.i386.rpm package. 

I have a /etc/gated.conf that has a static section that includes a default route.  I have not created a static default route in the routing tables outside of 
gated.  

When I start gated and look at the log file I see that it is doing an ADD on the default route, and it
is also listed in the gated dump (logs and dumps can be provided if needed).  The problem is
that netstat -rn does not show a default route in the routing table.

I can verify it's working because of the logs and by testing connectivity.
With gated on, I can reach the internet through my default route. With
gated off, I get network unreachable.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install gated-3.6-12
2.create /etc/gated.conf with a static section that includes a default route
3.start gated
4. look for default route with netstat -rn
	

Additional info:
Comment 1 abgrubbs 2002-01-10 19:14:59 EST
Created attachment 42251 [details]
gated dump file
Comment 2 abgrubbs 2002-01-10 19:16:19 EST
Created attachment 42252 [details]
gated log
Comment 3 abgrubbs 2002-01-10 20:37:33 EST
I have also tested gated 3.6-12 as simply a listener to rip updates and 
it receives the default route via rip, the log shows it's updating the kernel, 
but the default route is never displayed with netstat -rn.

As before I can verify the operational default route because the internet
is reachable as long as gated is running, and goes unreachable
as soon as I kill gated (and the log shows that default route is removed)

--Bert
Comment 4 Bill Nottingham 2006-08-07 15:09:52 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 12:34:22 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.