This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 58208 - Warnings about m4_patsubst
Warnings about m4_patsubst
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf253 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 19:42 EST by Enrico Scholz
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 02:45:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-01-10 19:42:36 EST
Description of Problem:

| $ cat >configure.ac <<'EOF'
| AC_INIT(X,1,X)
| AM_INIT_AUTOMAKE(X,1)
| AM_CONFIG_HEADER(x.h)
| AC_OUTPUT()
| EOF


gives warnings when executing autoconf:

| $ autoreconf
| configure.ac:3: warning: do not use m4_patsubst: use patsubst or m4_bpatsubst
| configure.ac:4: warning: do not use m4_regexp: use regexp or m4_bregexp
| autoreconf: `aclocal.m4' is unchanged
| autoheader: `x.h.in' is created

Since this m4_-stuff is on the M4sh/M4sugar level and has not appeared in
autoconf-2.52-4 (autoconf-2.52d) AFAIR, it may be an autoconf issue.


Version-Release number of selected/related component (if applicable):

autoconf-2.52-5
automake-1.5-2
m4-1.4.1-5
Comment 1 Jens Petersen 2002-03-27 01:35:09 EST
fixed by autoconf-2.53

Note You need to log in before you can comment on or make changes to this bug.