Bug 58255 - Fails to build with recent autoconf/automake
Fails to build with recent autoconf/automake
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: librsvg (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-11 20:43 EST by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-12 22:39:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-01-11 20:43:32 EST
Description of Problem:

librsvg fails to build with recent auto*-tools:

| $ rpm --rebuild librsvg-1.0.2-1.src.rpm 
| ...
| + automake
| automake: configure.in: required file `./depcomp' not found
| /usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
| /usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
| /usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
| /usr/share/automake/am/lang-compile.am: AMDEP does not appear in AM_CONDITIONAL
| error: Bad exit status from /var/tmp/rpm-tmp.8535 (%build)



Replacing the 

| automake
| autoconf

sequence in the %build-stage with

| %define __libtoolize :

fixes it.


Version-Release number of selected/related component (if applicable):

librsvg-1.0.2-1.src.rpm
automake-1.5-4
autoconf-2.52-5
Comment 1 Havoc Pennington 2002-01-12 22:39:17 EST
Thanks, we are doing an automated rebuild of stuff now and I'm going to fix all
these "en masse" - I'm going to go ahead and close the bug since there are
several dozen such bugs, and I'll know about them because I'll be forced to make
the automated rebuild work.

Note You need to log in before you can comment on or make changes to this bug.