Bug 582664 - Brightness controls do not work after resume
Brightness controls do not work after resume
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
: 591258 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 10:32 EDT by James Laska
Modified: 2013-09-02 02:47 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 16:01:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/{messages,dmesg,Xorg.0.log} (364.25 KB, application/x-compressed-tar)
2010-04-15 10:32 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-04-15 10:32:33 EDT
Created attachment 406817 [details]
/var/log/{messages,dmesg,Xorg.0.log}

Description of problem:

While testing https://fedoraproject.org/wiki/QA:Testcase_nouveau_suspend, it seems that brightness controls work *BEFORE* suspend.  *AFTER* resume, they no longer work.

Version-Release number of selected component (if applicable):

kernel-2.6.33.2-46.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-3.20100305git6b8b157.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-4.fc13.x86_64

How reproducible:

* 3 out of 3 attempts

Steps to Reproduce:
1. Follow instructions at https://fedoraproject.org/wiki/QA:Testcase_nouveau_suspend
  
Actual results:

Brightness controls do not work

Expected results:

Brightness controls should work after resume

Additional info:

 * NOT using a custom xorg.conf
 * I don't know if this is related to another upowerd problem I'm having on this system (see bug#580570)
Comment 1 James Laska 2010-04-15 10:33:11 EDT
02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9400M] (rev b1)
Comment 2 David Lawrence 2010-05-05 14:02:32 EDT
FWIW, this also occurs consistently in F12 as well with all the latest updates with the exact same hardware as jlaska (macbook pro). Please let me know as well if there is any additional info you need from me as well as any possible workarounds you may know of. The only way I have been able to re-enable brightness control it seems is by rebooting.

Dave
Comment 3 Bug Zapper 2010-07-30 07:21:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Williamson 2010-10-07 14:46:33 EDT
Hi, James. Is this still valid with current F13/F14? Thanks.
Comment 5 Adam Williamson 2010-10-07 15:40:18 EDT
*** Bug 591258 has been marked as a duplicate of this bug. ***
Comment 6 James Laska 2010-10-07 16:01:57 EDT
(In reply to comment #4)
> Hi, James. Is this still valid with current F13/F14? Thanks.

Would you look at that, the problem no longer occurs in F-14

 * kernel-2.6.35.5-30.fc14.x86_64
 * xorg-x11-drv-nouveau-0.0.16-12.20100920gitf1ac413.fc14.x86_64

Marking issue as CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.