Bug 58302 - cannot print, print filter crashes at Couldn't exec at /usr/sbin/lpdomatic line 629
cannot print, print filter crashes at Couldn't exec at /usr/sbin/lpdomatic li...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-13 16:43 EST by Martijn Kruithof
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 16:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martijn Kruithof 2002-01-13 16:43:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I configured the on a fresch installed system + all updates upto 11 jan 2002
(including  foomatic-1.1-0.20011018.7) to print on a canon 6200 with the
bjc610a8.upp driver. This fails however with the following messages in
/var/spool/lpd/lp/status.lp:

IF filter 'mf_wrapper' filter msg - '<' at 2002-01-13-22:21:24.664 ## A=<NULL>
number=389 process=26421
IF filter 'mf_wrapper' filter msg - 'gs  PID pid2=26453' at 2002-01-13-22:21:24.
667 ## A=<NULL> number=389 process=26421
IF filter 'mf_wrapper' filter msg - 'Couldn't exec  at /usr/sbin/lpdomatic line 
629.' at 2002-01-13-22:21:24.669 ## A=<NULL> number=389 process=26421
IF filter 'mf_wrapper' filter msg - 'tail process done writing data to *main::ST
DOUT' at 2002-01-13-22:21:24.688 ## A=<NULL> number=389 process=26421
IF filter 'mf_wrapper' filter msg - '/usr/sbin/lpdomatic: prepended:' at 2002-01
-13-22:21:24.698 ## A=<NULL> number=389 process=26421
IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at 2002-01-13-22:21:24
.707 ## A=<NULL> number=389 process=26421
IF filter 'mf_wrapper' filter msg - 'Error closing pipe to  at /usr/sbin/lpdomat
ic line 422, <STDIN> line 416.' at 2002-01-13-22:21:24.707 ## A=<NULL> number=38
9 process=26421
IF filter 'mf_wrapper' filter exit status 'JFAIL' at 2002-01-13-22:21:24.724 ## 
A=<NULL> number=389 process=26421
printing finished at 2002-01-13-22:21:24.724 ## A=<NULL> number=389 process=2642
1
accounting at end at 2002-01-13-22:21:24.725 ## A=<NULL> number=389 process=2642
1
finished 'cfA389jkf.jkf', status 'JFAIL' at 2002-01-13-22:21:24.725 ## A=<NULL>
number=389 process=26421
subserver pid 26421 exit status 'JFAIL' at 2002-01-13-22:21:24.727 ## A=<NULL> n
umber=0 process=26390
job 'cfA389jkf.jkf', attempt 3, allowed 3 at 2002-01-13-22:21:24.729 ## A=<NULL>
 number=389 process=26390
send_failure_action 'JREMOVE' at 2002-01-13-22:21:24.729 ## A=<NULL> number=389 
process=26390
job 'cfA389jkf.jkf', removing job - status JREMOVE at 2002-01-13-22:21:24.729 ##
 A=<NULL> number=389 process=26390
removing job 'cfA389jkf.jkf' - JREMOVE at 2002-01-13-22:21:24.730 ## A=<NULL> nu
mber=389 process=26390

It seems that the commandline is not correctly built in the lpdomatic script.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create printer (local printer lp on /dev/lp0, CANON BJC 6200, one of the
bjc610[ab][0-8] drivers, others not tried)
2.Try too print a testpage
3.See logfile
	

Actual Results:  IF filter 'mf_wrapper' filter msg - '<' at
2002-01-13-22:38:17.112 ## A=<NULL> number=583 process=26613
IF filter 'mf_wrapper' filter msg - 'gs  PID pid2=26624' at
2002-01-13-22:38:17.115 ## A=<NULL> number=583 proces
s=26613
IF filter 'mf_wrapper' filter msg - 'Couldn't exec  at /usr/sbin/lpdomatic line
629.' at 2002-01-13-22:38:17.118 
## A=<NULL> number=583 process=26613
IF filter 'mf_wrapper' filter msg - '/usr/sbin/lpdomatic: prepended:' at
2002-01-13-22:38:17.125 ## A=<NULL> numb
er=583 process=26613
IF filter 'mf_wrapper' filter msg - 'tail process done writing data to
*main::STDOUT' at 2002-01-13-22:38:17.136 
## A=<NULL> number=583 process=26613
IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at
2002-01-13-22:38:17.149 ## A=<NULL> number=583 proce
ss=26613
IF filter 'mf_wrapper' filter msg - 'Error closing pipe to  at
/usr/sbin/lpdomatic line 422, <STDIN> line 416.' a
t 2002-01-13-22:38:17.149 ## A=<NULL> number=583 process=26613
IF filter 'mf_wrapper' filter exit status 'JFAIL' at 2002-01-13-22:38:17.166 ##
A=<NULL> number=583 process=26613
printing finished at 2002-01-13-22:38:17.166 ## A=<NULL> number=583 process=26613
accounting at end at 2002-01-13-22:38:17.166 ## A=<NULL> number=583 process=26613
finished 'cfA583jkf.jkf', status 'JFAIL' at 2002-01-13-22:38:17.167 ## A=<NULL>
number=583 process=26613
subserver pid 26613 exit status 'JFAIL' at 2002-01-13-22:38:17.168 ## A=<NULL>
number=0 process=26584
job 'cfA583jkf.jkf', attempt 3, allowed 3 at 2002-01-13-22:38:17.170 ## A=<NULL>
number=583 process=26584
send_failure_action 'JREMOVE' at 2002-01-13-22:38:17.170 ## A=<NULL> number=583
process=26584
job 'cfA583jkf.jkf', removing job - status JREMOVE at 2002-01-13-22:38:17.171 ##
A=<NULL> number=583 process=2658
4
removing job 'cfA583jkf.jkf' - JREMOVE at 2002-01-13-22:38:17.172 ## A=<NULL>
number=583 process=26584


Expected Results:  hardcopy on paper

Additional info:

[root@jkf root]# printconf-tui --Xexport > settings.xml
[root@jkf root]# more settings.xml
<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1010957918">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <lp ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="413673"/>
            <gs_driver TYPE="STRING" VALUE="bjc610a8.upp"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          </lp>
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>
Comment 1 Tim Waugh 2002-01-14 03:33:17 EST
This has similaries to bug #55547.
Comment 2 Tim Waugh 2002-01-15 12:39:05 EST
Hm, this is because for some reason 'prototype' is empty for that driver.  
There are several other drivers with empty prototypes too.  Investigating.
Comment 3 Tim Waugh 2002-01-18 06:17:44 EST
Hmm, apparently an empty prototype field means that it isn't supported.

Does the 'omni' driver for that printer work?
Comment 4 Martijn Kruithof 2002-01-18 11:50:00 EST
It worked upto 7.1 with that driver.
Printconf also gives an stp driver option, no omni driver though.
The stp driver also doesn't work -sModel misses.
Is the printer database editable by users?
Comment 5 Tim Waugh 2002-01-18 12:49:10 EST
It isn't editable, no (not easily).  But you should have an 'omni' driver if 
you've installed all the applicable updates to date.

Please make sure you have applied the updates for Red Hat Linux 7.2.  You 
should end up with:

foomatic-1.1-0.20011018.7.i386.rpm
Omni-0.5.0-4.i386.rpm
Omni-foomatic-0.5.0-4.i386.rpm
printconf-0.3.52-1.i386.rpm
ghostscript-6.51-16.i386.rpm

Let me know if there is an omni driver after doing that, and if that provides 
better results.
Comment 6 Martijn Kruithof 2002-01-19 05:58:58 EST
[jkf@kruithof html]$ rpm -q foomatic Omni Omni-foomatic printconf ghostscript
foomatic-1.1-0.20011018.7
Omni-0.5.0-4
Omni-foomatic-0.5.0-4
printconf-0.3.52-1
ghostscript-6.51-16

No Omni shows up for canon bjc6200
Comment 7 Martijn Kruithof 2002-01-19 06:12:28 EST
I "Solved" the problem the following way:
[root@kruithof root]# rpm -e foomatic Omni-foomatic printconf printconf-gui
warning: /etc/alchemist/namespace/printconf/local.adl saved as
/etc/alchemist/namespace/printconf/local.adl.rpmsave
[root@kruithof root]# rpm -i /home/jkf/printconf-
printconf-0.2.15-2.i386.rpm      printconf-gui-0.2.15-2.i386.rpm
[root@kruithof root]# rpm -i /home/jkf/printconf-*


(I removed foomatic and the new printconf and installed the printconf from rh
7.1 (latest patchlevel))
Comment 8 Tim Waugh 2002-01-24 06:55:21 EST
Do the packages at <ftp://people.redhat.com/twaugh/errata-candidate/> help?
Comment 9 Martijn Kruithof 2002-01-24 16:14:41 EST
Yes, the uniprinter at least works again in 360x360 dpi modes. STP driver does 
not work. The options are not filled in in the command line:

IF filter 'mf_wrapper' filter msg - 'GNU Ghostscript 6.51 (2001-03-28)' at 
2002-01-24-21:16:07.011 ## A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - 'Copyright (C) 2001 artofcode LLC, 
Benicia, CA.  All rights reserved.' at 2002-01-24-21:16:07.011 ## 
A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - 'This software comes with NO WARRANTY: see 
the file COPYING for details.' at 2002-01-24-21:16:07.011 ## 
A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - 'Printer must be specified with -sModel' 
at 2002-01-24-21:16:07.657 ## A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - '**** Unable to open the initial device, 
quitting.' at 2002-01-24-21:16:07.658 ## A=root@kruithof+886 number=886 
process=888
IF filter 'mf_wrapper' filter msg - 'Couldn't exec foomatic-gswrapper -q -
dSAFER -dNOPAUSE -dBATCH -sDEVICE=stp  -sOutputFile=- - at /usr/sbin/lpdomatic 
line 749.' at 2002-01-24-21:16:07.705 ## A=root@kruithof+886 number=886 
process=888
IF filter 'mf_wrapper' filter msg - 'tail process done writing data to 
*main::STDOUT' at 2002-01-24-21:16:07.705 ## A=root@kruithof+886 number=886 
process=888
IF filter 'mf_wrapper' filter msg - 'KID4 finished' at 2002-01-24-21:16:07.706 
## A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at 2002-01-24-
21:16:07.706 ## A=root@kruithof+886 number=886 process=888
IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at 2002-01-24-
21:16:07.706 ## A=root@kruithof+886 number=886 process=888

Thanks, at least it works again.
Comment 10 Tim Waugh 2002-01-25 08:28:24 EST
Okay.  Well, the gimp-print driver (formerly named 'stp') seems to work in
rawhide now at least, so I'll mark this as fixed.  The other problem will be
fixed when the errata goes out.

Note You need to log in before you can comment on or make changes to this bug.