Bug 58303 - net.agent should do wireless initialization even when network is down.
net.agent should do wireless initialization even when network is down.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: hotplug (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-13 17:39 EST by Aleksey Nogin
Modified: 2007-04-18 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 17:58:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-01-13 17:39:18 EST
To reproduce:
1) With network service stopped, insert a pcmcia wireless card
2) Start network
Note - this sequence of events will happen "on its own" when a laptop is resumed
with
PCMCIARESTART="yes"
PCMCIABIOSBUG="yes"
NET_RESTART="yes"
in /etc/sysconfig/apmd and a wireless card plugged in before resume (for
example, never taken out after suspend).

Expected: 
Everything works fine.

Actual: 
If a card is inserted before network is started, the /etc/hotplug/net.agent
would not do anything. Because of that the /etc/pcmcia/wireless is never called
and the intarface would fail tp activate properly.

IMO, there are two ways of solving this:
A) In /etc/hotplug/net.agent, move the test for /var/lock/subsys/network *after*
the wireless stuff. This makes sense, since hotplug should do proper
initialization of the hardware even if we do not plan to use it right away.

B) Move the call to /etc/pcmcia/wireless to /sbin/ifup. This may be an even
better idea.
Comment 1 Trond Eivind Glomsrxd 2002-01-28 15:41:05 EST
I like B better too... Bill?
Comment 2 Aleksey Nogin 2002-07-17 17:58:54 EDT
It seems that "B" indeed happened in Limbo - there is no longer any
/etc/pcmcia/wireless...

Note You need to log in before you can comment on or make changes to this bug.