Bug 58311 - RunWM has infinite loop if all fallbacks fail
RunWM has infinite loop if all fallbacks fail
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-13 22:48 EST by Morey Hubin
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 04:52:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morey Hubin 2002-01-13 22:48:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.4.0-XFS i686)

Description of problem:
  I have a RedHat 7.2 system with both the RH7.1 2.4.2 and RH7.2 2.4.7 kernels.
Boot into 2.4.2 and gdm works for everyone. Reboot into 2.4.7 and only UID=0
accounts can get passed gdm.  Harddrive swaps hard for 60 seconds before Xserver
dies and gdm recovers with a login dialog again.  All this is AFTER the pam
module patch was installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Redhat 7.2 with NIS configured.
2. Update nsswitch.conf with "files nis" for passwd, shadow and group.
3. Apply latest pam_unix patches to fix major login problem.
4. Reboot and login with UID!=0 account and X stalls w/ mad swapping
      Until gdm kills xserver and starts with login dialog again.

Actual Results:  While the Xserver is swapping ctrl-alt-backspace the xserver,
login
at the text console as root and you will see dozens of RunWM -help calls and one
RunWM -FVWM95 (Fvwm95, where did that come from???).
If /usr/bin is not in your path, then exec gnome-session and exec startkde fail,
leaving 

Expected Results:  Users with UID!=0 should be able to login. :)

Additional info:

/etc/X11/xinit/Xclients needs PATH=/usr/bin:$PATH or gnome-session is not found
for non-root users.  If you don't have Fvwm95 (the last ditch WM) then RunWM
goes into an infinate loop fork()'ing RunWM -help calls.  Because of the dual
kernel boot setup it is clear that the kernel is the start of the problem. 
`login` is not setting PATH or something is killing /bin and /usr/bin from the
PATH.  Regardless of
the cause PATH=/bin:/usr/bin:$PATH should be there.
Comment 1 Havoc Pennington 2002-01-18 18:07:53 EST
PATH is supposed to come from /etc/profile I believe. I don't have any initial
idea on where it is getting lost; no one else has reported this issue.

Maybe there are issues with not finding user home dirs or user shells due to the
info in NIS... I'm just guessing though.
Comment 2 Havoc Pennington 2002-02-11 18:47:38 EST
I'm not going get get anywhere on this without a way to reproduce it.

Infinite loop in RunWM should be fixed though, so moving to xinitrc (Probably
fvwm95 should be cleaned out of there, and RunWM should just bail to twm.)
Comment 3 Mike A. Harris 2002-08-12 07:16:13 EDT
Does this problem occur with RHL 7.3 and/or the current Limbo beta, or
is it resolved now?  Please update.
Comment 4 Mike A. Harris 2002-12-15 04:52:38 EST
Assuming the problem is resolved now due to lack of response. If problem
continues, reopen bug report and provide the details and answers requested
above.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.