Bug 583205 - F13 Beta Won't Boot - NFS Mount Point in /etc/fstab Hangs Boot Process
F13 Beta Won't Boot - NFS Mount Point in /etc/fstab Hangs Boot Process
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
13
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 22:22 EDT by mark
Modified: 2011-06-27 11:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: nfs-utils-1:1.2.2-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 11:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 2010-04-16 22:22:47 EDT
Description of problem:
Installed F13 Beta on new partition. Everything booted correctly. When I added the following line to /etc/fstab and rebooted then the system hangs at "Mounting nfs filesystems".
192.168.1.2:/shares/SimplePool/BACKUP /media/SIMPLESHARE nfs defaults 0 0

However, Using F12 the fstab line above does mount the nfs filesystem correctly.

Also, I am able to manually mount the filesystem in F13 Beta with the following command:
mount -t nfs 192.168.1.2:/shares/SimplePool/BACKUP /media/SIMPLESHARE

So something seems to be going wrong during boot.

How reproducible:
Every time the system is booted, it hangs if there's a nfs filesystem that's trying to be mounted via /etc/fstab

Steps to Reproduce:
1. Add an entry that mounts an nfs filesystem in /etc/fstab
2. Reboot
  
Actual results:
System hangs.

Expected results:
System mounts nfs filesystem and boots properly.

Workaround:
Disable nfs mount line in /etc/fstab (but had to do that from my other os, F12, since I couldn't boot into F13)
Comment 1 Dan 2010-06-02 12:12:27 EDT
Just wanted to add I see this problem on the released F13 and did not see it on F12.  My system eventually boots, it just takes a while for the NFS mount to timeout.  I've tried adding bg,timeo=14 in /etc/fstab for the NFS entry to let it be mounted in the background with no success.
Comment 2 Steve Dickson 2010-06-04 10:54:38 EDT
Now that F-13 is released... is thies still happening? If so what
version nfs-utils are you using (i.e. rpm -q nfs-utils)
Comment 3 Dan 2010-06-04 14:00:56 EDT
I actually found a solution.  

In network Manager, I selected the option to let the wireless connection be used by all users.  I think this let the network come up automatically, so now the NFS mount happens at boot instead of timing out.  I can look up the version of nfs-utils later.  I am using the latest available in Fedora 13.

I would still expect to not see this happen if the network doesn't come up for some reason.  The options that nfs suggests to add to fstab didn't solve the problem.
Comment 4 mark 2010-06-05 13:45:21 EDT
Yes this still happens in full release of F13.  Interestingly, this same problem used to happen in Ubuntu 9.10, but F12 worked.  Now, Ubuntu 10.04 mounts the nfs external drive (connected wirelessly) properly, while F13 doesn't.
Comment 5 Rudd-O DragonFear 2010-06-16 16:20:34 EDT
Still happens on Fedora 13.  The bg mount option is not respected in the fstab options field.
Comment 6 Rudd-O DragonFear 2010-06-16 16:22:31 EDT
It does say "mount.nfs4: backgrounding..." after one minute or so.  But that's not the expected behavior -- if the filesystem is to be mounted on boot as a background mount, then I would expect it to be mounted properly in the background when the machine boots.

Every time I power up my machine at work, it's the same problem, since the NFS server is not here.
Comment 7 Rudd-O DragonFear 2010-06-16 16:24:15 EDT
fwiw, I see in the process list:

/sbin/mount.nfs4 10.254.102.1:/shared /var/shared -o rw,noexec,nosuid,nodev,users,_netdev,bg

It is *okay* if /etc/init.d/netfs does this on boot.  It just should be done as a background process altogether.
Comment 8 Steve Dickson 2010-10-15 18:25:49 EDT
I'm able to reproduce this with a fully updated F13 machine... 

Anybody have a clue as to how I can reproduce this?
Comment 9 Steve Dickson 2010-10-15 18:49:49 EDT
Here latest release

https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13

Please down load test to see if you are still able to see this problem

tia...
Comment 10 mark 2010-10-15 22:06:56 EDT
Problem is Fixed!

After manually mounting my nfs nas share for months, I recently decided to uncomment my mounting line in /etc/fstab and now my computer doesn't hang while booting and mounts correctly once the wireless connection starts.

Obviously I don't know which update fixed the problem for me, but I'm currently running a fully update F13 computer with "nfs-utils-1:1.2.2-2.fc13" installed.
Comment 11 Bug Zapper 2011-06-02 11:13:02 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2011-06-27 11:39:56 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.