Bug 58331 - DB4: db4-devel doesn't obsolete db3-devel
DB4: db4-devel doesn't obsolete db3-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 11:13 EST by Jonathan Kamens
Modified: 2013-07-02 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 06:51:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-14 11:13:09 EST
This is actually a db4 bug, not a db3 bug, but I'm submitting it under db3
because there's no db4 category in bugzilla.

When I try to install the db4 packages, I get:

jik:/usr/src/packages/new!24> rpm -U --test *
file /lib/libdb.so from install of db4-devel-4.0.14-1 conflicts with file from
package db3-devel-3.2.9-5
file /usr/include/db.h from install of db4-devel-4.0.14-1 conflicts with file
from package db3-devel-3.2.9-5
file /usr/lib/libdb_cxx.so from install of db4-devel-4.0.14-1 conflicts with
file from package db3-devel-3.2.9-5

It looks to me like db4-devel doesn't know that it obsoletes db3-devel.
Comment 1 Jindrich Novy 2006-02-15 06:51:33 EST
Ok, fixed since db4-4.3.29-2. Thanks.

Note You need to log in before you can comment on or make changes to this bug.