Bug 583588 - mode in mkdir-mode is still affected by umask
mode in mkdir-mode is still affected by umask
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-19 03:19 EDT by Yufang Zhang
Modified: 2010-04-19 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-19 16:35:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yufang Zhang 2010-04-19 03:19:42 EDT
Description of problem:
When I create a directory via mkdir-mode, mode of the newly-created dir is still affected by umask.  


Version-Release number of selected component (if applicable):
major: 1
minor: 3
release: 4
extra: 

How reproducible:
Always

Steps to Reproduce:
1.><fs> mkdir-mode /test-dir 0777
mkdir_mode "/test-dir" 511

2.><fs> ll /
ll "/"
total 24
drwxr-xr-x  4 root root  4096 Apr 19 03:24 .
drwxr-xr-x 20 root root     0 Apr 18 22:44 ..
drwx------  2 root root 16384 Apr 19 01:51 lost+found
drwxr-xr-x  2 root root  4096 Apr 19 03:24 test-dir

3. ><fs> umask 022
umask 18
022

  
Actual results:
mode is still affected by umask.

Expected results:
mode in mkdir-mode is not affected by umask.

Additional info:
Comment 1 Richard W.M. Jones 2010-04-19 16:35:34 EDT
We cannot change this because of the ABI guarantee, so I'm
closing this.  See also:

https://bugzilla.redhat.com/show_bug.cgi?id=583554#c1

Note You need to log in before you can comment on or make changes to this bug.