Bug 58359 - include ext2resize in next release
include ext2resize in next release
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 19:00 EST by Chris Ricker
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 05:25:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-01-14 19:00:24 EST
(filed against e2fsprogs 'cause its related software and I don't know where to
file meta-distribution RFEs)

ext2resize <http://ext2resize.sourceforge.net/index.html> provides the ability
to resize (both grow and shrink) ext2 and ext3 filesystems offline, and to grow
ext2 filesystems online.  It seems to be full-featured and stable.  It'd be a
nice addition to the next release of Red Hat.
Comment 1 Florian La Roche 2002-03-07 14:04:23 EST
It does not seem to support ext3 and this would be a requirement to include
it for future Red Hat Linux versions.

cu,

Florian La Roche
Comment 2 Chris Ricker 2002-03-07 14:16:40 EST
Actually, it does support ext3.  From the spec file:

Description :
Programs and man pages for tools that resize second extended (ext2)
filesystems (including journalled ext2 filesystems, also called ext3).
Included are tools for offline (unmounted) and online (mounted)
resize of filesystems.  Online filesystem resizing requires support
in the kernel (patches for which are included herein).

and I've used it on several ext3 filesystems as well, so I can also vouch that
it does work with them.
Comment 3 Chris Ricker 2002-06-10 00:15:48 EDT
Now that it's new release time, might this be considered?
Comment 4 Florian La Roche 2002-12-03 16:33:21 EST
Closing, the current e2fsprogs release contains resize2fs.

greetings,

Florian La Roche

Comment 5 Chris Ricker 2002-12-03 17:00:12 EST
Reopening -- I'd still like ext2resize included

The two tools aren't equivalent. resize2fs can only resize unmounted
filesystems, while ext2resize toolset supports resizing mounted filesystems
Comment 6 Chris Ricker 2004-01-21 09:23:40 EST
Reopened -- this isn't in the current release, nor in the development
tree AFAICT
Comment 7 Thomas Woerner 2004-11-22 05:25:06 EST
There is ext2online for online resize in FC-3 and RHEL-4.

Note You need to log in before you can comment on or make changes to this bug.