Bug 583747 - libudev.h does not include C++ support to avoid mangling.
libudev.h does not include C++ support to avoid mangling.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-19 11:59 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 07:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2010-04-19 11:59:31 EDT
The libudev.h should include preprocessor details to avoid mangling when compiled into a C++ application.
Comment 1 Kay Sievers 2010-05-09 13:24:58 EDT
I guess that's fixed since udev 151 year, and should not be in the rawhide version:
http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=3fac12b9a05f1849f7b1373060ade18269839856

Note You need to log in before you can comment on or make changes to this bug.