Bug 58422 - Update rh 7.2 with glibc 2.2.4-19.3 impossible
Update rh 7.2 with glibc 2.2.4-19.3 impossible
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-16 06:22 EST by Nicolas CROISET
Modified: 2016-11-24 09:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 22:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas CROISET 2002-01-16 06:22:24 EST
Description of Problem:

When I upgade Rh7.2 new installation with the new packages of glibc 2.2.4-19.3,
I obtain this :

Version-Release number of selected component (if applicable):


How Reproducible:
rpm -qa | grep glibc
glibc-2.2.4-13
glibc-common-2.2.4-13
[root@mymachine newglibc]# ll glibc-*
-rw-r--r--    1 root     root      5193282 dic 13 16:14 glibc-2.2.4-19.3.i386.rpm
-rw-r--r--    1 root     root      8966908 dic 13 16:14
glibc-common-2.2.4-19.3.i386.rpm
-rw-r--r--    1 root     root     10202456 dic 13 16:14
glibc-devel-2.2.4-19.3.i386.rpm
-rw-r--r--    1 root     root      8902606 dic 13 16:14
glibc-profile-2.2.4-19.3.i386.rpm
[root@mymachine newglibc]# rpm -Fvh glibc-*
Preparing...                ########################################### 
[100%]
    1:glibc-common           ########################################### 
[ 50%]
    2:glibc                  ########################################### 
[100%]
ls: /lib/ld-.so.soerror: execution of %trigger scriptlet from 
anonftp-4.0-9 failed, exit status 0
[root@mymachine newglibc]# ls /lib/ld-.so.soerror
ls: /lib/ld-.so.soerrorSegmentation fault
[root@mymachine newglibc]# mount /mnt/cdrom
Segmentation fault
Comment 1 Jakub Jelinek 2002-01-28 06:42:19 EST
The trigger error is because you haven't upgraded anonftp first.
The segfaulting is weird, by any chance, weren't you upgrading from i686
glibc to i386 glibc?
Comment 2 Nicolas CROISET 2002-01-30 02:54:46 EST
No, I don't think it was i686 package before (original install of redhat 7.2 on
PIV).

There was an update of anonftp ?!! It was the original anonftp from the distrib
redhat 7.2.
Comment 3 Jakub Jelinek 2002-01-30 04:22:41 EST
Oopsie, anonftp was buggy in 7.1, not 7.2.
But if you're on PIV, installer installed 100% i686 glibc package.
i686->i386 "upgrades" don't work properly, you need to rm -rf /lib/i686 too,
because rpm for some reason does not wipe it out.
Comment 4 Alain D D Williams 2002-04-17 04:20:54 EDT
I have done the same thing ... ended up with a system where almost anything
died with a segmentation fault, eg 'ls -l', but not 'ls -ln'. Thanks for the
comment about removing /lib/i686 - it got me back again (after an ldconfig).

The point is that it is easy to do. Thinks ``better install the upgrading RPM'',  
not realising that the i686 glibc is installed. Also there does not seem to be a
complete set of glibc in i686 ...

Looking at: ftp://updates.redhat.com/7.2/en/os/
in i386 I see:
   glibc-2.2.4-24.i386.rpm
   glibc-common-2.2.4-24.i386.rpm
   glibc-devel-2.2.4-24.i386.rpm
   glibc-profile-2.2.4-24.i386.rpm
in i686 I only see:
   glibc-2.2.4-24.i686.rpm

What do I install to get my system back as a full i686 system again ?
Comment 5 Ulrich Drepper 2003-04-21 22:45:23 EDT
User bug in obsolete release.  No reason to keep this open.  If a user insists
on using rpm to force the installation s/he better knows when to use the i386
and when to use the i686 binary.  Yes, rpm should catch this but it's hard and
up2date won't make such a mistake.  So, use up2date and RHN.

Note You need to log in before you can comment on or make changes to this bug.