Bug 58443 - loader: failed to set default route
loader: failed to set default route
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-16 13:55 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 20:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-16 13:55:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
When doing a kickstart installation using DHCP, the following error is reported:

"<11>Jan 15 17:58:42 loader: failed to set default route: Network is unreachable"

After this point it fails its NFS mount and brings up the interactive install
process.  During the interactive install process, if you specify to obtain an IP
through DHCP it receives the IP address fine and can peform the NFS mount. 
Clearly this is not a DHCP issue because the install receive a valid response,
but only when it is done interactively.  This is done with Compaq DL320 hardware
and the latest ISC DHCP Server.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Peformed DHCP kickstart installation using Compaq DL320 on eth0
2.Watched the install process.
3.Watch install fail.
	

Actual Results:  "<11>Jan 15 17:58:42 loader: failed to set default route:
Network is unreachable"


Expected Results:  It should obtain the default router and carry on.

Additional info:

The virtual console of the install actually shows that it received the default
router from the dhcp server.

here is a dump below (IPs #'d out to protect the innocent).

###PUMP: got lease
<15>Jan 15 17:58:42 loader: intf: device: eth0
<15>Jan 15 17:58:42 loader: intf:set: 288
<15>Jan 15 17:58:42 loader: intf: bootServer: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: reqLease: 0
<15>Jan 15 17:58:42 loader: intf: bootFile: pxelinux.0
<15>Jan 15 17:58:42 loader: intf: ip: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: next server: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: netmask: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: gateway: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: dnsServers[0]: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: dnsServers[1]: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: numDns: 2
<15>Jan 15 17:58:42 loader: intf: domain: cool.mydomain.com
<15>Jan 15 17:58:42 loader: intf: broadcast: ###.###.###.###
<15>Jan 15 17:58:42 loader: intf: network: ###.###.###.###
<4>nfs warning: mount version older than kernel
<7>eth0: 0 multicast blocks dropped.
<11>Jan 15 17:58:42 loader: failed to set default route: Network is unreachable
Comment 1 Michael Fulbright 2002-01-16 14:25:02 EST
I think it would help to know what some of the #'s were, otherwise its going to
be hard to debug.  We have not had this problem reported before so we'll have to
dig deeper.
Comment 2 Need Real Name 2002-01-16 14:43:44 EST
You got it, here's the message with IP info, thanks.

###PUMP: got lease
<15>Jan 15 17:58:42 loader: intf: device: eth0
<15>Jan 15 17:58:42 loader: intf:set: 288
<15>Jan 15 17:58:42 loader: intf: bootServer: 192.168.81.71
<15>Jan 15 17:58:42 loader: intf: reqLease: 0
<15>Jan 15 17:58:42 loader: intf: bootFile: pxelinux.0
<15>Jan 15 17:58:42 loader: intf: ip: 192.168.81.39
<15>Jan 15 17:58:42 loader: intf: next server: 192.168.83.40
<15>Jan 15 17:58:42 loader: intf: netmask: 255.255.255.128
<15>Jan 15 17:58:42 loader: intf: gateway: 192.168.81.1
<15>Jan 15 17:58:42 loader: intf: dnsServers[0]: 192.168.6.60
<15>Jan 15 17:58:42 loader: intf: dnsServers[1]: 192.168.6.61
<15>Jan 15 17:58:42 loader: intf: numDns: 2
<15>Jan 15 17:58:42 loader: intf: domain: unilab.digex.com
<15>Jan 15 17:58:42 loader: intf: broadcast: 192.168.81.127
<15>Jan 15 17:58:42 loader: intf: network: 192.168.81.0
<4>nfs warning: mount version older than kernel
<7>eth0: 0 multicast blocks dropped.
<11>Jan 15 17:58:42 loader: failed to set default route: Network is unreachable
Comment 3 Michael Fulbright 2002-01-21 15:56:27 EST
Thanks, assigning to an engineer.
Comment 4 Jeremy Katz 2002-01-21 20:45:17 EST
This is in pump because the ioctl() to set the default route failed for some
reason...
Comment 5 Need Real Name 2002-01-24 17:15:28 EST
Problem between screen and chair. Fixed.  Sorry guys.  Problem was specifying
the wrong default gateway in the kickstart file.

Note You need to log in before you can comment on or make changes to this bug.