Bug 58455 - gimp crashes converting large image from RGB to indexed
gimp crashes converting large image from RGB to indexed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gimp (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-16 22:17 EST by Jonathan Kamens
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 17:42:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-16 22:17:31 EST
Using the xsane gimp plugin, I scanned an 8.5x11 page in color at 600 DPI.  When
I attempted to convert it to indexed mode, by selecting Image -> Mode ->
Indexed... and accepting the default setting, gimp crashed with this error:

Gimp-ERROR **: file convert.c: line 2345 (median_cut_rgb): assertion failed:
(b2->Gmax >= b2->Gmin)
aborting...
gimp terminated: Aborted

LibGimp-WARNING **: script-fu: wire_read: unexpected EOF

If I convert the image to 300 DPI (i.e., scale it to 0.5 / 0.5) and try again,
the conversion works, which suggests that perhaps the problem is somehow related
to how large the file is.

I'm reluctant to attach the file in question to this bug report, because it's
almost 17MB even after I bzip2 it.  Instead I will describe it to you on the off
chance that you will be able to duplicate it -- white paper, blue letterhead and
footer, black typing covering most of the rest of the page.  The content of the
paper may not even be relevant; the size may be enough to cause the problem.  In
any case, if you can't duplicate it, please let me know and I suppose I can
attach the file to this bug or upload it to somewhere you can copy it from.
Comment 1 Matt Wilson 2002-12-14 19:48:14 EST
can you put the file up for download somewhere?
Comment 2 Jonathan Kamens 2003-01-14 02:02:40 EST
You're asking me in December to make available a file associated with a bug I
reported in January?

No, I'm afraid I don't have the file handy, and I can't attempt to reproduce it
right now because I just discovered that the bulb on my scanner is burned out. 
I'll try to get a new bulb and see if I can reproduce the problem with it.
Comment 3 Jonathan Kamens 2003-01-24 14:36:56 EST
I can no longer duplicate this problem with gimp-1.2.3-13.  Furthermore, the
error which was previously fatal has apparently been turned into a non-fatal
warning -- when I try to do the conversion described above now, I get
"Gimp-WARNING **: nope: b2->Gmax >= b2->Gmin" and gimp keeps running (and
successfully converts the image).  So I guess you can close this bug.

Note You need to log in before you can comment on or make changes to this bug.