Bug 584682 - KMS:RV670:HD3850:AGP GPU lockup
KMS:RV670:HD3850:AGP GPU lockup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
13
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 03:39 EDT by Steve
Modified: 2010-04-27 03:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 03:12:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (33.92 KB, text/plain)
2010-04-22 06:01 EDT, Steve
no flags Details
lspci (1.33 KB, text/plain)
2010-04-22 06:01 EDT, Steve
no flags Details
dmesg (36.33 KB, text/plain)
2010-04-22 10:43 EDT, Steve
no flags Details
lspci (1.33 KB, text/plain)
2010-04-22 10:43 EDT, Steve
no flags Details

  None (edit)
Description Steve 2010-04-22 03:39:16 EDT
Description of problem:
New version of xorg freezes


Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.8.0-7.fc13.i686
xorg-x11-drv-vesa-2.3.0-1.fc13.i686
xorg-x11-server-Xorg-1.8.0-7.fc13.i686

How reproducible:
Always


Steps to Reproduce:
1. Yum update
2. Reboot
3.
  
Actual results:
Xorg freezes

Expected results:
X should not freeze

Additional info:
Messages:

Apr 22 09:37:56 StarsEnd kernel: INFO: task Xorg:1295 blocked for more than 120 seconds.
Apr 22 09:37:56 StarsEnd kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Apr 22 09:37:56 StarsEnd kernel: Xorg          D 0000001c  5320  1295   1288 0x00400084
Apr 22 09:37:56 StarsEnd kernel: f1bbbda4 00003046 0fb3c73b 0000001c 00000000 c3b49740 c0ade470 c0c23180
Apr 22 09:37:56 StarsEnd kernel: c0c23180 c0c23180 f1fb1844 00000000 00000006 f1bbbd8c 00000000 f01c5200
Apr 22 09:37:56 StarsEnd kernel: 0000001c f1fb15a0 f5c30cbc f1bbbd9c c04698d9 f5c30cb8 f5c30cb8 f1fb15a0
Apr 22 09:37:56 StarsEnd kernel: Call Trace:
Apr 22 09:37:56 StarsEnd kernel: [<c04698d9>] ? trace_hardirqs_on_caller+0x104/0x125
Apr 22 09:37:56 StarsEnd kernel: [<c07c57ed>] __mutex_lock_common+0x1f2/0x30a
Apr 22 09:37:56 StarsEnd kernel: [<c07c59b2>] mutex_lock_nested+0x35/0x3d
Apr 22 09:37:56 StarsEnd kernel: [<f7fac4fd>] ? radeon_cs_ioctl+0x29/0x16c [radeon]
Apr 22 09:37:56 StarsEnd kernel: [<f7fac4fd>] radeon_cs_ioctl+0x29/0x16c [radeon]
Apr 22 09:37:56 StarsEnd kernel: [<c04c8430>] ? might_fault+0x4c/0x86
Apr 22 09:37:56 StarsEnd kernel: [<c07c6e3f>] ? _lock_kernel+0x64/0x74
Apr 22 09:37:56 StarsEnd kernel: [<f7e68a42>] drm_ioctl+0x26d/0x32b [drm]
Apr 22 09:37:56 StarsEnd kernel: [<f7fac4d4>] ? radeon_cs_ioctl+0x0/0x16c [radeon]
Apr 22 09:37:56 StarsEnd kernel: [<c045e777>] ? sched_clock_cpu+0x125/0x12d
Apr 22 09:37:56 StarsEnd kernel: [<c0468516>] ? trace_hardirqs_off+0xb/0xd
Apr 22 09:37:56 StarsEnd kernel: [<c0468516>] ? trace_hardirqs_off+0xb/0xd
Apr 22 09:37:56 StarsEnd kernel: [<c0596ed5>] ? file_has_perm+0x8f/0xa9
Apr 22 09:37:56 StarsEnd kernel: [<c04f3bc1>] vfs_ioctl+0x2c/0x96
Apr 22 09:37:56 StarsEnd kernel: [<f7e687d5>] ? drm_ioctl+0x0/0x32b [drm]
Apr 22 09:37:56 StarsEnd kernel: [<c04f4174>] do_vfs_ioctl+0x49b/0x4d9
Apr 22 09:37:56 StarsEnd kernel: [<c0597179>] ? selinux_file_ioctl+0x43/0x46
Apr 22 09:37:56 StarsEnd kernel: [<c04f41f8>] sys_ioctl+0x46/0x66
Apr 22 09:37:56 StarsEnd kernel: [<c07c6f14>] syscall_call+0x7/0xb
Apr 22 09:37:56 StarsEnd kernel: [<c07c0000>] ? allocate_threshold_blocks+0x145/0x1be
Apr 22 09:37:56 StarsEnd kernel: 1 lock held by Xorg/1295:
Apr 22 09:37:56 StarsEnd kernel: #0:  (&rdev->cs_mutex){+.+.+.}, at: [<f7fac4fd>] radeon_cs_ioctl+0x29/0x16c [radeon]
Comment 1 Jérôme Glisse 2010-04-22 05:06:05 EDT
Please attach dmesg and lspci output.
Comment 2 Steve 2010-04-22 06:01:20 EDT
Created attachment 408279 [details]
dmesg
Comment 3 Steve 2010-04-22 06:01:40 EDT
Created attachment 408280 [details]
lspci
Comment 4 Jérôme Glisse 2010-04-22 06:35:00 EDT
Try adding radeon.agpmode=-1 to your kernel boot line and report if it works.
Comment 5 Steve 2010-04-22 06:58:54 EDT
Yes, this works. But does it slow down the AGP-Mode?
Comment 6 Jérôme Glisse 2010-04-22 09:48:45 EDT
Please try kernel at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2132377

Once it done building (without the radeon.agpmode=-1 option)
Comment 7 Steve 2010-04-22 10:43:28 EDT
Created attachment 408346 [details]
dmesg

kernel-2.6.33.2-60.fc13.i686 is also not working.
Comment 8 Steve 2010-04-22 10:43:52 EDT
Created attachment 408347 [details]
lspci
Comment 9 Steve 2010-04-22 10:55:11 EDT
I don't know if it makes a difference, but i used kernel-PAE before..
Comment 10 Jérôme Glisse 2010-04-22 12:24:51 EDT
When does Xorg freeze ? With a particuliar application ?
Comment 11 Steve 2010-04-22 12:40:10 EDT
It freezes just after log-in with gdm.
Comment 12 Steve 2010-04-22 12:44:37 EDT
...since today's updates:

Apr 22 09:11:41 Updated: ibus-libs-1.3.2-1.fc13.i686
Apr 22 09:11:57 Updated: 1:gdm-2.30.0-1.fc13.i686
Apr 22 09:11:57 Updated: xorg-x11-server-common-1.8.0-7.fc13.i686
Apr 22 09:11:58 Updated: xorg-x11-drv-vesa-2.3.0-1.fc13.i686
Apr 22 09:12:01 Updated: xorg-x11-server-Xorg-1.8.0-7.fc13.i686
Apr 22 09:12:11 Updated: ibus-1.3.2-1.fc13.i686
Apr 22 09:12:12 Updated: ibus-gtk-1.3.2-1.fc13.i686
Apr 22 09:12:17 Updated: webkitgtk-1.2.0-1.fc13.i686
Apr 22 09:12:18 Updated: nss-softokn-freebl-3.12.4-17.fc13.i686
Apr 22 09:12:24 Installed: 1:tcl-8.5.7-5.fc13.i686
Apr 22 09:12:26 Updated: telepathy-glib-0.10.1-3.fc13.i686
Apr 22 09:12:42 Updated: empathy-2.30.0.2-1.fc13.i686
Apr 22 09:12:43 Updated: nss-softokn-3.12.4-17.fc13.i686
Apr 22 09:12:44 Updated: ibus-rawcode-1.3.0.20100421-1.fc13.i686
Apr 22 09:12:45 Updated: 1:gdm-user-switch-applet-2.30.0-1.fc13.i686
Apr 22 09:12:45 Updated: 1:gdm-plugin-fingerprint-2.30.0-1.fc13.i686
Apr 22 09:12:46 Updated: usb_modeswitch-1.1.2-1.fc13.i686
Apr 22 09:12:48 Installed: usb_modeswitch-data-20100418-2.fc13.noarch
Comment 13 Steve 2010-04-27 03:12:19 EDT
This bug is fixed with today's updates, closing.

Fixed in:
xorg-x11-server-Xorg-1.8.0-8.fc13.i686
xorg-x11-server-common-1.8.0-8.fc13.i686

Note You need to log in before you can comment on or make changes to this bug.